cancel
Showing results for 
Search instead for 
Did you mean: 

Problem when trying to connecting to the SLD...

Former Member
0 Kudos

HI All,

When i am trying to connecting to the SLD as

http://<ip address> : portnumber /sld ...it is giving an error

You do not have permission to view the System landscape directory. \r\n\r\n Minimum required.UME Role with permission com.sap.lcr.LcrUser and J2EE role LcrUser.

SLD not configured ; configure the SLD in Administration first.

I tryed to configure using SLD post -installation giude, but it is not happing,so cud u please help me out to solve this.

thanks a lot

vish

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Viswanadh

do following.

SLD (System Landscape Directory) CONFIGURATION on J2EE Server.

http://host:j2ee_port/sld

Enter Administrator user name and password.

Go to Administration -> Server Settings

Make sure that the SLD server is stopped

Enter the following Server Parameters

Object Server:

<Host name of the J2EE server>

Working Directory:

The working directory of the System Landscape Directory.

The standard path is "/usr/sap/<SAPSID>/SYS/global/sld"

Click on SET.

Select the following parameter for Persistence

Persistence: Database

Click on SET.

Leave ABAP Connection Parameters Blank.

Go back to Administration.

Click on Data Supplier Bridge

Configure the data supplier bridge with following parameters.

Update local SLD (sld/active): TRUE

RFC Gateway:

Server : <host name of J2EE server>

Service : <The SAP gateway service port>

Click on SET.

Open Administration Tool for J2EE server from following Location.

C:\usr\sap\<SID>\JC<instance number>\j2ee\admin\go.bat

Select Default and Click on Connect.

Enter password for Administrator.

Click on Connect.

Select Cluster->Server->Services->SLD Data Supplier

Select http setting tab page and enter following details.

Host: <host name of J2EE server>

Port: <Port Number of J2Ee Server>

User: <Administrator User>

Password: <Password for Administrator User>

Use https? : <Check this if you want to use https>

Trust Store: <leave default i.e. TrustedCAs>

Click on SAVE.

Select RFC Settings tab page and enter following details.

Gateway Host : <host name of J2EE server>

Gateway Service/Port: sapgw<instance number>

Click on SAVE.

Restart the SLD data Supplier Service.

if u configure ESS webdynpro for ERP2004 mail me on kaushalmalavia@yahoo.com

any query revert back.

regards,

kaushal

Former Member
0 Kudos

Thanks a lot kaushal,it is working fine.

i really appriciate ur prompt reply.

vish

Answers (0)