cancel
Showing results for 
Search instead for 
Did you mean: 

Problem when run command fiori add deploy-config

beampakorn
Explorer
0 Kudos

got the error 

Do you need to install @Sap/generator-fiori globally?
npm install -g @Sap/generator-fiori
OR
yarn global add @Sap/generator-fiori<br>


after run command  

fiori add deploy-config

my system

MTA version v1.0.8
Cloud MTA Build Tool version 1.2.27
Node version 22.1.0


SAP Cloud Application Programming Model  SAP Fiori for SAP S/4HANA 
 

beampakorn
Explorer
0 Kudos

-

beampakorn
Explorer
0 Kudos
I already try MTA version 1.0.4 and MBT 1.0.4 but the problem still there

Accepted Solutions (0)

Answers (1)

Answers (1)

junwu
Active Contributor
0 Kudos
npm install -g @Sap/generator-fiori

just do it.

beampakorn
Explorer
0 Kudos
that the first thing I done after
beampakorn
Explorer
0 Kudos
that the first thing I done after error shown up but doing this still nothing happen
junwu
Active Contributor
0 Kudos
where is your error infomation????
beampakorn
Explorer
0 Kudos
the block
beampakorn
Explorer
0 Kudos
the block "Do you need to install @Sap/generator-fiori globally?" from my post is error information
beampakorn
Explorer
0 Kudos
sorry for double comment i try shift+enter to break the line but it just auto comment with unfinished msg
junwu
Active Contributor
0 Kudos
did it install anything? I saw S is in upper case, which is not correct.
beampakorn
Explorer
0 Kudos
i install with lower case "npm install -g @Sap/generator-fiori" and re run command again but still not working
beampakorn
Explorer
0 Kudos
I solve this issue by using my other pc to run "fiori add deploy-config" command i dont know why my other pc work but my working laptop is not working all version of node package and nodejs version is exactly the same
beampakorn
Explorer
0 Kudos
I also try to upload my cap project to BAS and run add deploy config at BAS terminal but the result is not working same with my laptop
beampakorn
Explorer