cancel
Showing results for 
Search instead for 
Did you mean: 

Problem #TOREFRESH with "Where" in 4.1 SP3 variables

Former Member
0 Kudos

Hi lads,

We have recently upgraded our BO system from 4.0 SP5 to BO 4.1 SP3.

We have solved all incidents we had during the upgrade process, except one, and we don't know what to try or do else.

I explaine you. We have a webi which mixes HR and COPA data, and it's splitted by Business Area.  We have 3 business area in our company, so do 3 similar webis.  This split is just for roles and authorizations.

Webis are built over a BEx OLAP connection.

In BO 4.0 all the 3 webis work fine.  In BO 4.1 2 of them work fine, and just one have an issue, which is that is showing #TOREFRESH in some formulas and variables.

We have tried:

- Refresh connections (saving and recreating).

- Refesh queries (saving)

- Recreate variables and formulas.

- Refreshing report (thousand of times).

- Queries BEx are fine, retested and rechecked.

What we have discovered is the following: error happens when in the formula there is a KeyFigure followed by a "Where" clause, and if we substitute the KeyFigure for a new Variable variable with a ForEach, it works.

For example:

1. Current formula (which works in 2/3 of webis, and in 3/3 webis in BO 4.0)

= [Key Figure1] Where [Structure]="TESTTESTTESTTEST"

--> #TOREFRESH error

2. Create new variable:

= [Key Figure1] ForEach [Structure]="TESTTESTTESTTEST"

3. Substitution KeyFigure by Variable:

= [New Variable] Where [Structure]="TESTTESTTESTTEST"

--> No error.

We would like to know if any of you have had the same incident, and we can avoid to modify so many variables and formulas.

Thanks

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

HI ,

Trying creating a univ on top of the query.

or go thorugh the following threads , will give more details,

http://scn.sap.com/thread/2147021

cheers

ganesh

Former Member
0 Kudos

Hi Ganesh,

We had already checked that post and in it it's not said that univers on top of the query would solve the issue. Besides that, we tried the solution provided in that post and it didn't work for us.

Anyway, creating a univ it's a big change, even bigger than modifying our formulas and variables, and we want to avoid big changes and big efforts.

Thanks

former_member207052
Active Contributor
0 Kudos

First of all I really appreciate the fact that you have done some real analysis on the issue.

Can check if you have enabled "Query stripping" and if so can you try to disable it and run the web-I report once to rule out that part of the puzzle ?

Also, in my opinion, this is a good candidate for SAP's support and if you have not done already you can raise a ticket to make some real progress with the issue.

Regards,

Naras

Former Member
0 Kudos

Hi Naras,

We tried both things, with and without Query stripping, and no result.

We have found these two OSS SAP Notes:

2020466 - #TOREFRESH shown for delegated measures in migrated Web Intelligence reports even after mu...

2097971 - Unable to refresh webi document properly due to “#TOREFRESH” error

As it looks like it's a known issue by SAP.  If after checking those 2 Notes we are in the same situation, we will do what you say, contact SAP.

Thanks

Answers (0)