cancel
Showing results for 
Search instead for 
Did you mean: 

Problem in building the development component

Former Member
0 Kudos
39

Actually I was trying to Build one of the development component I developed I found the error given below

May 17, 2007 6:39:40 PM /userOut/Development Component (com.sap.ide.eclipse.component.provider.listener.DevConfListener) [Thread[ModalContext,5,main]] ERROR: model: Build failed for sap.com/model(MyComponents) in variant "default": Unable to find a javac compiler;

com.sun.tools.javac.Main is not on the classpath.

Perhaps JAVA_HOME does not point to the JDK

Then I found JDK was not installed on my machine then I installed the JDK but it is giving same error yet, can any body help me to set the path or class pth so that I can be able to build my DC.

Thanks

Sandeep

Accepted Solutions (1)

Accepted Solutions (1)

Greg_Austin
Active Participant
0 Kudos

Sandeep open a windows command prompt (start->run->cmd) and type "set" without the quotes. What is the value of JAVA_HOME?

Answers (3)

Answers (3)

Greg_Austin
Active Participant
0 Kudos

Other things besides the NWDS might use the JAVA_HOME variable. To set it in windows right click on My Computer->properties->Advanced Tab->Environment Variables. Create a new System variable called JAVA_HOME and point it to the jdk directory. C:\j2sdk1.4.2_13 on my machine.

former_member186016
Active Contributor
0 Kudos

Hi,

The installed JDK is not specified in your IDE.

Go to Windows->Preferences-> Java->Installed JREs ... Give path to your JDK here.

Better give path to JDK not JRE, because build searches for compiler also.

Regards,

Ashwani Kr Sharma

Former Member
0 Kudos

Hi Sandeep,

Go to Window->Perspective->Java->Installed JRE.add ur jdk path here.It will work.

regards

Sumit

Former Member
0 Kudos

I have just added as per your suggestion but it is giving me the same error.

Former Member
0 Kudos

Hi Sandeep,

Just check whether classpath variables r specified.window->preferences->classpath variables. Here JRE_LIB has to be specified as rt.jar & JRE_SRC as src.zip.Hope it will work.

regards

Sumit

former_member186016
Active Contributor
0 Kudos

Try this also.

Right click on shortcut to SapIde.exe. Go tp properties. In Target you must be having following

<b><<i>ide-installation-dir</i>>\eclipse\SapIde.exe -java</b>

Edit it to make :

<b><<i>ide-installation-dir</i>>\eclipse\SapIde.exe -java "<<i>JDKInstallation</i>>\bin\javaw.exe".</b>

Then use this shortcut to launch your IDE.

Regards,

Ashwani Kr Sharma