cancel
Showing results for 
Search instead for 
Did you mean: 

Problem in BEX

Former Member
0 Kudos

Hi BW Experts,

Can any one help on this plz.

Thanks a million in advance.

we have standard keyfigures in the cube 0cca_c03 cube.cube is updated from R/3.For some periods(months) data(keyfigures) is in decimals like 7.5,6.5 .But when i execute the Bex report,7.5 becomes 8 and 6.5 becoms 7.Have tried by changing the KF's propertis(no of of decimal places) but no use.

Keyfigures in the cube are Quantiaty and average Quantity and data type is ' Quantity' and unit of measure is '0UNIT'.Can anybody help me out to display the values in the report as they are in the Cube.

Xys redd.

Accepted Solutions (0)

Answers (5)

Answers (5)

Former Member
0 Kudos

Hi xys redd

Did you get this issue solved , I am facing a similar situation , could you share your work around.

Thanks

Former Member
0 Kudos

Hi, I have the same problem. Did you find any solution? None of the suggestions worked...

Thanks

Marek

Former Member
0 Kudos

OK I've got it. The problem was caused by wrong setting for the unit of measurement. My key figure is in MWh. I check the settings for MWh in SPRO - general setting - chceck units of measurement - there is a setting for rounding decimal places. I set that to 999. the query looks good now.

Bye

Marek

Former Member
0 Kudos

Hi Xys,

Please check if you have any conversion routine used for the infoObjects for these key figures. If yes, remove the conversion routine and give it a try.

Abdul

Former Member
0 Kudos

Have you checked the cell format functions in Excel in BEx Analyzer?

Please make sure it is set to decimals instead of rounding-off.

Former Member
0 Kudos

Dear All,

No conversion routines are used for Keyfigures "

"Cell format is set to decimals only not rounded off in excel in Bex analyzer"

Plz. help

xyz redd.

Former Member
0 Kudos

xyz..

You could try checking how the data appears in the infocube itself.

Go to RSA1 and then select the infocube and "manage".

Next go to the contents tab and then view the data from there.

This will show you how the data is stored in the infocube right now.

Former Member
0 Kudos

Hi,

did you check the attributes of the keyfigures in the bex? May it is set to no decimals there. Are you displaying the keyfigures itself or are you displaying some formulas, selections ...? May be there is a wrong setting. What about the size of the cells in Excel? Did you increase the cell size? Are you using a template? If yes check the cell format in EXCEL.

regards

Siggi

Former Member
0 Kudos

Please check the key figures InfoObjects definition in BW using RSD1.

Former Member
0 Kudos

Hi Ravi and Gupta

" data is stored in the cube with dcimals

like 6.5,7.5,.....etc...when ever data is in decimals in cube its rounding off to next integer for example 6.5 becomes 7 ,and 7.5 becomes 8."

data type for key figs is "Quantity" and unit of measure is "0UNIT".

in keyfig maintaince bex decimals set to 0.000.

plz. advice

xys redd.

former_member188975
Active Contributor
0 Kudos

Have you checked the data in the cube...I mean is it stored with decimals or is it rounded off.