cancel
Showing results for 
Search instead for 
Did you mean: 

Problem executin WebI report from BO Platform (HANA)

Former Member
0 Kudos

Hello all,

I have a very weird problem with a report I have developed:

- I have a HANA server with a view created. I can view all the data without problems.

- I have developed a Universe from this view. The universe has developed with my laptop and I haven't got any problems. (the connection to hana is a relational JDBC one)

- I have developed a report from this universe with Webi Rich Client on my laptop and I can view the report without problems.

Now, the problems come when I try to execute the report from the BI Platform (4.1 SP6). The report gives this generic error when opening it:

An intern error has happened calling the API 'processDPCommandsEx'. (Error: ERR_WIS_30270) (Error: INF )

If I try to refresh the data of the report, the error is this: while trying to invoke the method com.sap.connectivity.cs.core.DbParameterSet$DomainParameterSet.getFunctions() of a null object returned from java.util.Map.get(java.lang.Object)

Another clue is that If I try to open the Universe from the IDT installed on the BI Platform server, the connection gives me the same error: while trying to invoke the method com.sap.connectivity.cs.core.DbParameterSet$DomainParameterSet.getFunctions() of a null object returned from java.util.Map.get(java.lang.Object)

So at the end it seems a connectivity problem with the JDBC driver installed on my BI Platform Server, but I have tried like 15 diferent versions of the ngdbc.jar driver and none makes the report work.

Any tips? I'm getting really frustated with this problem.


Thanks to all!

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Have you tried to consume the Uinverse created with other reporting tool (e.g. Crystal reports, etc.)?

Former Member
0 Kudos

Have you ruled out the network connection between the BI platform and HANA server?

Former Member
0 Kudos

Yes, we don't have any problem in the network as our OLAP connections to HANA defined in the CMC that we use with SAP Design Studio work without problems.

Thanks