cancel
Showing results for 
Search instead for 
Did you mean: 

Problem creating iOT Application on webide

Former Member

Hi,

I'm trying to create an app on webide, from the iOT Application template. Everything runs smoothly until I get to the part where i'me supposed to select the property set Type and the property set. It tells me to select the property from the list but the list is empty.

Where are this properties defined?

In the previous wizard step I defined the following:

With the destination:

Do you have any idea what the problem might be?

thank you!

Accepted Solutions (0)

Answers (5)

Answers (5)

marcus_behrens
Advisor
Advisor
0 Kudos

Please also make sure you cover the trust configuration described at https://blogs.sap.com/2017/10/24/trust-configuration-between-sap-cloud-platform-neo-account-and-sap-... (official documentation is at help.sap.com > SAP IoT Application Enablement > SAP IoT Application Enablement Reuse Controls and Templates > IoT Application Projects in SAP Web IDE > Prerequisites > Configuring SAML Trust between Neo Environment and Cloud Foundry Environment)

0 Kudos

Hi Fernando

Can you please share how your problem was resolved on this topic ?

Thanks.

Former Member
0 Kudos

hey fernando

You could solve the problem?? if yes how???

thank you

WouterLemaire
Active Contributor
0 Kudos

It's not available yet in the trial account. See point 9 on this blog:

https://blogs.sap.com/2017/01/09/sap-iot-application-enablement-jump-page/

Trial
(still to be provided, until then check with partner program or sap sales for a test license)

Former Member
0 Kudos

thx for your answer

Former Member
0 Kudos

Hello Anton,

thank you for the reply.

Do I need to configure all those tables(IOTAS-COMPOSITE-THINGS-ODATA, IOTAS-COMPOSITE, etc.) on the SAP CP destinations? To configure those destinations I need some credentials that are provided by sapiotappenablement@sap.com. I requested them last week but unfortunately didn't get any response so far.

As for the service, I am using the oData Service exposed by SAP Cloud Platform so I guess that is not the problem.

cheers

anton_levin
Employee
Employee
0 Kudos

You would need the "IOTAS-COMPOSITE-THINGS-ODATA" destination (Table 4 on that list) and then select it in step 4 from this [1] procedure.

"As for the service, I am using the oData Service exposed by SAP Cloud Platform so I guess that is not the problem." -> As I told, you use oData API exposed by IoT MMS. This particular WebIDE plugin expects an oData service exposed by "IOTAS-COMPOSITE-THINGS" service and configured with HTTP destination in your account.

Regards,

Anton

[1] https://help.hana.ondemand.com/webide_iotapptemplates/frameset.htm?f8e49bdacbbd429da0662b64127a6f12....

anton_levin
Employee
Employee
0 Kudos

Hello Fernando,

you are using WebIDE plug-in for the IoT Application Enablement but try to feed it with OData Service exposed by SAP Cloud Platform Internet of Things (Message Management Service - iotmms).

Please, follow this instructions [1] and create necessary destinations required by the IoT Application Enablement plugin.

Regards,

Anton

[1] https://help.hana.ondemand.com/webide_iotapptemplates/frameset.htm?b11e8ace511c492693a16aaca082552d....