cancel
Showing results for 
Search instead for 
Did you mean: 

Print control.cab is not downloading in Client machine

Former Member
0 Kudos
516

Hi,

In particular machine crystal report is launching fine in IE8. While clicking the print button print dialogue box has appearing as empty window but itu2019s working in all other machines.

On downloading the Printcontrol.cab the fiddler response code as 200 but the required dll (printcontrol.dll) is not available in Downloaded Program Files folder.

If I register the printcontrol.dll manually the print is working fine. But if I unregister the printcontrol.dll print is not working.

I have added the URL in trusted sites and also enabled required IE settings and web.config settings, but still Printcontrol.cab is not getting downloaded.

Export and other toolbar options are working well.

This has been simulated particular client machine only. Please help me to overcome this issue.

Environment Details:

Operating system: Windows 7 Starter Edition (32 bit)

Internet Explorer version : IE8

Crystal Report Version in Server: Crystal Reports XI Release2

Thanks in Advance.

View Entire Topic
0 Kudos

Hello,

Check your WEB.Config file, it should have the XI R2 crviewer version you are using. IIS then should check the version on the client PC and send the new crviewer.cab file down to the PC.

It may also be security settings on the client PC, not allowing ActiveX controls to be installed.

I don't have R2 installed any more but the CrystalReportsViewer folder should be in your c:\Inetpub\wwwroot folder. If it isn't then check permissions and search, lots of posts and kbase articles on how to resolve.

Don