cancel
Showing results for 
Search instead for 
Did you mean: 

Port 0 in URL from WAS

Former Member
0 Kudos
217

Hello everybody,

we want to use the web-reporting delivered with the SAP BW 3.0b. Everything seems to be installed, but when I want to open a report in the IE out of the Web Application Designer, I always get an URL like this:

http://xxxxxxxxx:

0

/sap/bw/BEx?sap-language=DE&bsplanguage=DE&CMD=LDOC&TEMPLATE_ID=......

and the answer that the page cannot be displayed. I am sure that the reason for this behaviour is the port 0 in the URL. Since the administrator is under heavy workload at the moment, can somebody give me a hint where to customize the port, so that it´ll work?

Regards,

Accepted Solutions (0)

Answers (1)

Answers (1)

former_member181887
Active Contributor
0 Kudos

Hi Sebastian,

Can check the following instance profile parameters:

icm/server_port_0

icm/plugin_0

These parameters define the HTTP port and path to the ICM plug-in (HTTP) that you will use. You can define more ports for other protocols (HTTPS, SMTP, etc)

For load balancing, you should also set the following parameters:

ms/http_port (or ms/https_port)

rdisp/mshost

These parameters define the central Message server host and port. The message server port is usually on the central instance (host) and the port must be unique not the same port as used in the parameters icm/server_port_X

Examples of parameter settings:

icm/server_port_0 = PROT=HTTP,PORT=1080

icm/server_port_1 = PROT=HTTPS,PORT=8000

icm/server_port_2 = PROT=SMTP,PORT=8025

icm/plugin_0 = PROT=HTTP,PLG=F:\usr\sap\<SID>\SYS\exe\run\httpplugin.dll

icm/plugin_1 = PROT=HTTPS,PLG=F:\usr\sap\<SID>\SYS\exe\run\httpplugin.dll

icm/plugin_2 = PROT=SMTP,PLG=F:\usr\sap\<SID>\SYS\exe\run\smtpplugin.dll

ms/http_port = 1081

ms/https_port = 8001

rdisp/mshost = <Message Server host>

Once these are set you need to stop and start your BW system.

Finally, check that your BW ICF services are active. These are delivered inactive for security reasons . You can do this in transaction SICF. Navigate to default_host -> SAP -> BW. Ensure ALL the subcomponents are active [Black, not grey] - right click on each subcomponent to activate.

You can test your setting using the url:

http://<host>:<port>/sap/BW/BEx

The result should be the standard Web Template tool bar (and any system messages)

(I think we will have a small how-to delivered on this topic)

I hope this helps,

Mike.

former_member181887
Active Contributor
0 Kudos

Hi,

A How-To paper for this problem should be posted on the BW page of the SAP Service Marketplace tomorrow.

(http://service.sap.com/BW -> Service and Implementation).

Have fun,

Mike.