cancel
Showing results for 
Search instead for 
Did you mean: 

PI home page

Former Member
0 Kudos

Hi Experts,

I didn't work with PI for few years, and got into a very basic problem here (embarrassing...) : how to get to PI home page?

I am here now:

and want to get to here:

How can I get to the home page of PI?

Thank you in advance for your kind reply.

Blue

Accepted Solutions (1)

Accepted Solutions (1)

sateesh_adma
Participant
0 Kudos

go to SXMB_IFR t code , you will get to PI tools home page

Answers (6)

Answers (6)

former_member186851
Active Contributor
0 Kudos

Try adding the PI host name in the windows hosts file.

Former Member
0 Kudos

I entered the translation code, but I got this, does this mean I am not authorized?

former_member184720
Active Contributor
0 Kudos

Your configuration might be incorrect.

As is said, why don't you access with the direct URL.

http:// host : port/ dir/start/index.jsp

Former Member
0 Kudos

At our PI 7.11 dual stack the home page is at

http://fqdn:portnumber/dir/start/index.jsp

The page requires no authentication.

Former Member
0 Kudos

Hi Hareesh, I  tried using the URL, it doesn't work either, got the same error page

former_member184720
Active Contributor
0 Kudos

Are you sure if the Java stack is up/running fine? make sure that you got the valid J2EE port.

Former Member
0 Kudos

How do I know which Port SAP PI should use?
I used "netstat" checked, seems there are bunch of ports running

former_member184720
Active Contributor
0 Kudos

it should be 5<<system number>>00. You should be able to find it in smicm transaction as well.

Former Member
0 Kudos

The left is from smicm, the right is from netstat, seems no two ports are the same from both sides. I also added the host to my hosts file as Raghuraman suggested, still not working

former_member184720
Active Contributor
0 Kudos

I don't think they are port number.

go to SMICM -> click on Services(SHIFT+ F1)

here you should be able to find http port.

In addition, did you try with system number? i.e. 5<<system number>>00 should be your port in general.

Former Member
0 Kudos

Hi Hareesh,

This is all the port number from SMICM, I tried them all, it didn't work. I did add the host to hosts file. How do I know J2EE allow any of the port number below and how to check System number?

Blue

Former Member
0 Kudos

Found the system number/instance number which is 00, so the port number should be 50000. I tried http://host:50000/dir/start/index.jsp

still can't open the PI home page.

What the problem could be?

former_member184720
Active Contributor
0 Kudos

Your java stack might be down. Check with basis/ check yourself, if you have access to MMC

Former Member
0 Kudos

I don't have access to MMC, but the helpdesk people said Java stack is fine (that's all they can tell me, they don't know further information).

Still can't access PI/XI home page

former_member186851
Active Contributor
0 Kudos

Blue check for any proxy setting that might be blocking the page.

Former Member
0 Kudos

Hi Blue,

Does your peers could able to access ?

If you are in client network ,then ideally you could able to access if the server is up.

If you are not in client location then usually you need to add the host entries in hostfile (run-->drivers-->etc-->hostfile) .Maintain IP and hostname .You may also need to bypass the proxy for the PI host.It varies from network to network.

Regards

Venkat

Former Member
0 Kudos

Hi Raghuraman, I am already in the client's network. So it shouldn't be the proxy issue

Former Member
0 Kudos

Hi Venkat, I did add the host to my hosts file and I am already in the client's network, since I can access SAP ECC

azharshaikh
Active Contributor
0 Kudos

Hi Blue,

Few checks as follows:

1. Ensure you are in client network & connection is not disconnected

2. Check if you are able to Ping the PI host

3. Verify from your colleagues if you are using the correct PI homepage URL

4. Check if you have added correct entries in Host file

5. Check if the Proxy connection (if any) is setup correctly in your IE browser settings

6. Try to launch other Env (QA/PROD) PI homepage and check if you are able to launch it.

Regards,

Azhar

Former Member
0 Kudos

Try adding the PI host name in the windows hosts file

former_member186851
Active Contributor
0 Kudos

There are chances blue, Ensure whether any proxy settings(server/port) to be maintained.

In my project , I need to add some proxy details to access the PI page even though I am in the client network.

Former Member
0 Kudos

Hi Guys,

Thank you so much for all your kind response. Now I remember transaction code SXMB_IFR.

Blue

former_member184720
Active Contributor
0 Kudos

How did you get there? jnlp file?

anyway - Your homepage address should be

http:// host : port/ dir/start/index.jsp

Replace host and port.

You could have searched SCN

sahithi_moparthi
Contributor
0 Kudos

Hi,

Use TCODE: SXMB_IFR,it will open PI home page.

TCODE for reference:

SXMB_IFR -> PI homepage

SXMB_MONI -> PI monitoring

Former Member
0 Kudos

Hi,

if this is PI dual stack,

type SXMB_IFR transaction code.