cancel
Showing results for 
Search instead for 
Did you mean: 

PI 7.11 - SXI_CACHE Issue - SQL0904 - Resource limit exceeded

Former Member
0 Kudos

Hi IBM I Gurus,

We are having the SXI_CACHE issue in our PI 7.11 SPS04 system. When we try to do the delta cache refresh through SXI_CACHE, it is returning the error SQL 0904 - Resource limit exceeded. When we try to do the full cache refresh, it is getting the issue 'Application issue during request processing'.

We have cleaned up the SQL Packages with DLTR3PKG command, which did not resolve the issue. We recently performed a system copy to build the QA instance and I observed that the adapter engine cache for the development is presented in the QA instance and removed that cache from there.

I am not seeing the adapter engine connection data cache in our PI system. The adapter engine cache is working fine.

All the caches are working fine from the PI Administration page. The cache connectivity test is failing with the same error as I mentioned for the SXI_CACHE.

Please let me know if you have encountered any issue like this on IBM I 6.1 Platform.

Your help is highly appreciated.

Thanks

Kalyan

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Kalyan,

Have seen your issue solved, congratulations!

Thanks for the coorperation and support for our investigation from DB4 side.

Best regards.

Jennifer

Former Member
0 Kudos

Hi Kalyan,

SQL0904 has different reason codes ...

Which one are you seeing ?

Is the SQL pack really at its boundary of 1GB ?

... otherwise, it is perhaps a totally different issue ... then DLTR3PKG cannot help at all ...

If you should see this big SQL Package, you should use PRTSQLINF in order to see if there is more or less over and over the same SQL in, just with different host variables or so ...

If the last point should be the case, I would open a message with BC-DB-DB4 so that they can check how to help here or to talk to the application people to behave a bit different ...

Regards

Volker Gueldenpfennig, consolut international ag

http://www.consolut.com http://www.4soi.de http://www.easymarketplace.de