cancel
Showing results for 
Search instead for 
Did you mean: 

Performance

neeta_patel2
Participant
0 Kudos

Hi all,

Has anyone noticed the portal to slow down after it has been up and running for a while, in our case a couple of days. We are seeing this and there is one jlaunch process that seems to consume a lot of CPU resources and the resource allocation does not seem to be going down. There are approximately 3 users on the Portal who all notice a performance degradation.

Note that the performance is good when the Java engine and Portal is first started.

We are running NW04, EP6, SP13, Solaris, Oracle.

The hardware is 4 CPUs 1.6GHz, 8GB RAM.

Best Regards, Neeta

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Neeta,

Generate a Java thread dump and you can check what is causing the issue. To know more about java thread dumps use the following links.

http://java.sun.com/developer/technicalArticles/Programming/Stacktrace/

http://java.sun.com/developer/onlineTraining/Programming/JDCBook/stack.html

Cheers!!

Kiran

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi,

Did u follow the fine tunning procedure as per

https://websmp205.sap-ag.de/~sapidb/011000358700001480992005E.PDF

https://websmp205.sap-ag.de/~sapidb/011000358700000174632005E.PDF

Sap Note - 772752, 763789, 781685, 723909.

Analyzing High CPU usage by the J2EE Engine - 742395

Analyzing High CPU usage by the J2EE Engine: Solaris - 743206

https://media.sdn.sap.com/public/eclasses/bwp04/PortalTuning_files/Default.htm

Hope this helps,

Thanks,

Praveen

PS.Dont forget to reward points

Former Member
0 Kudos

Have you checked the garbage collection logs? I would look for allocation failures. Also use the threaddumpscan tool that you can download from SDN to look for issues.