cancel
Showing results for 
Search instead for 
Did you mean: 

Payload structure not matching with the data type

Former Member
0 Kudos
81

hi ,

When i receive my outbound idoc i get the seesion id in that idoc but my payload data for receiver doesnt show me the tags of session id .

can any one pls let me know where the problem could be

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

in ur XID-ID, pls re-import the IDOC struture

Former Member
0 Kudos

I am new to XI so can u pls elaborate the steps i mean u said in ur XID-ID

what that means

Former Member
0 Kudos

Hi sudhir ,

My IDOC structure in XI contains the field Session id but only in the XML payload it doesnt show me that although it is populated with data

prateek
Active Contributor
0 Kudos

Hi,

Make sure u have followed the necessary steps to post the idocs

/people/swaroopa.vishwanath/blog/2007/01/22/ale-configuration-for-pushing-idocs-from-sap-to-xi

/people/ravikumar.allampallam/blog/2005/02/23/configuration-steps-required-for-posting-idocsxi

<i>[Reward points if helpful]</i>

Regards,

Prateek

Former Member
0 Kudos

I followed these steps but then to my payload xml doesnt show me one field .

my payload xml file should contain session_id tag but it skips only this and remainng data is retrieved properly .......

I dont know how to get session id now

Former Member
0 Kudos

see my Payload structure on XML side is

<?xml version="1.0" encoding="UTF-8" ?>

- <ZSALES_IDOC_OUT>

- <IDOC BEGIN="1">

- <EDI_DC40 SEGMENT="1">

<TABNAM>EDI_DC40</TABNAM>

<MANDT>240</MANDT>

<DOCNUM>0000000000390264</DOCNUM>

<DOCREL>620</DOCREL>

<STATUS>30</STATUS>

<DIRECT>1</DIRECT>

<OUTMOD>2</OUTMOD>

<IDOCTYP>ZSALES_IDOC_OUT</IDOCTYP>

<MESTYP>ZSALES_MT_OUT</MESTYP>

<SNDPOR>SAPDEV</SNDPOR>

<SNDPRT>LS</SNDPRT>

<SNDPRN>DEVLCN240</SNDPRN>

<RCVPOR>A000000019</RCVPOR>

<RCVPRT>LS</RCVPRT>

<RCVPRN>LS_RECD</RCVPRN>

<CREDAT>20070519</CREDAT>

<CRETIM>192341</CRETIM>

<SERIAL>20070519192339</SERIAL>

</EDI_DC40>

- <ZSALES_SEGMENT_OUT SEGMENT="1">

<DIVISION>CM</DIVISION>

<DIV_NAME>Custom Mfg. Div.</DIV_NAME>

<ORD_VAL>180562.4</ORD_VAL>

<GROSS_VAL>840</GROSS_VAL>

<RETURN_VAL>0</RETURN_VAL>

<SALE_VALUE>840</SALE_VALUE>

<PEN_VALUE>0</PEN_VALUE>

</ZSALES_SEGMENT_OUT>

where as my outbound idoc structure contains following information

DIVISION CM

DIV_NAME Custom Mfg. Div.

ORD_VAL 180562.4

GROSS_VAL 840

RETURN_VAL 0

SALE_VALUE 840

PEN_VALUE 0

SESSION_ID 19052007072214522

i am not getting y my session id is not included in above XMl File although i have used the session id in my receiver data type and mapping is also proper can u pls help me out with this

Former Member
0 Kudos

see my Payload structure on XML side is

<?xml version="1.0" encoding="UTF-8" ?>

- <ZSALES_IDOC_OUT>

- <IDOC BEGIN="1">

- <EDI_DC40 SEGMENT="1">

<TABNAM>EDI_DC40</TABNAM>

<MANDT>240</MANDT>

<DOCNUM>0000000000390264</DOCNUM>

<DOCREL>620</DOCREL>

<STATUS>30</STATUS>

<DIRECT>1</DIRECT>

<OUTMOD>2</OUTMOD>

<IDOCTYP>ZSALES_IDOC_OUT</IDOCTYP>

<MESTYP>ZSALES_MT_OUT</MESTYP>

<SNDPOR>SAPDEV</SNDPOR>

<SNDPRT>LS</SNDPRT>

<SNDPRN>DEVLCN240</SNDPRN>

<RCVPOR>A000000019</RCVPOR>

<RCVPRT>LS</RCVPRT>

<RCVPRN>LS_RECD</RCVPRN>

<CREDAT>20070519</CREDAT>

<CRETIM>192341</CRETIM>

<SERIAL>20070519192339</SERIAL>

</EDI_DC40>

- <ZSALES_SEGMENT_OUT SEGMENT="1">

<DIVISION>CM</DIVISION>

<DIV_NAME>Custom Mfg. Div.</DIV_NAME>

<ORD_VAL>180562.4</ORD_VAL>

<GROSS_VAL>840</GROSS_VAL>

<RETURN_VAL>0</RETURN_VAL>

<SALE_VALUE>840</SALE_VALUE>

<PEN_VALUE>0</PEN_VALUE>

</ZSALES_SEGMENT_OUT>

where as my outbound idoc structure contains following information

DIVISION CM

DIV_NAME Custom Mfg. Div.

ORD_VAL 180562.4

GROSS_VAL 840

RETURN_VAL 0

SALE_VALUE 840

PEN_VALUE 0

SESSION_ID 19052007072214522

i am not getting y my session id is not included in above XMl File although i have used the session id in my receiver data type and mapping is also proper can u pls help me out with this

former_member91687
Active Contributor
0 Kudos

Hi,

When you test the mapping in the Integration Repository are you able to get the session id field in the target side? Hope the field is not disabled by mistake.

Check in SXMB_MONI under receiver payload of your message if you are able to see this field?

Regards,

Chandra

Former Member
0 Kudos

No I am not able to see the field session id in receiver payload

former_member91687
Active Contributor
0 Kudos

Hi,

Check your mapping, test your mapping in the integration repository and see if you are able to get the session id in the target side.

Regards,

Chandra

Former Member
0 Kudos

The field is enabled and the test mapping transmits data properly but my payload doesnt show me session id at all .

former_member91687
Active Contributor
0 Kudos

Hi,

The source structure is the IDOC and the target is the XML structure you have created, is this right?

To which field in the target are you mapping the ID to?

Check in IDX2 to check if the idoc metadata has all the segments, if not delete and reimport again.

Regards,

Chandra

Former Member
0 Kudos

hi

every thing is fine then too my payload is not showing me the session id

initially when i started with the scenarion i didnt had the session id field then i modified the idoc and target message type and reimported the idoc i cross verified with the message type and mapping that i have included in the directory and repository and its seems to be fine .

I have even importde the idoc ain ixd2 this also shows me the latest structure with field session id but the only place where i am not getting this field is in receiver opayload is there any thing other that i have to do which will refresh some settings .

former_member91687
Active Contributor
0 Kudos

Hi,

After you deleted the metadata data, reimported the IDOC, make sure you are using the latest IDOC structure, nad all objetcs are activated.

Maybe the cache is not updated, refresh the cache and try again.

Regards,

Chandra

Former Member
0 Kudos

Thanks

The problem is solved