Showing results for 
Search instead for 
Did you mean: 

Password did not match in SQL SERVER

0 Kudos


I'm back at it again, migrating another crystal reports dot net web application. You'd think at this point I would have identified and noted all the such luck... 🙂

So here's the situation. I've migrated my web application to a new server 2012.

I've copied my ODBC connections verbatim from the old server to the new server.

When I try to produce a report I get a "Password did not match that for the login provided" error in the sql error log. So I have discovered that the actual report that runs perfectly in the client with a sql user id & pw fails in the application. It seems the id & password I use to run the report in the client is what is trying to be used when I run the report in the application. It's like it's not correctly using the ODBC connection or something. It's as if it wants to use the rpt file id & pw verses anything else. As you know the pw isn't saved in the file, hence the failed login. But why is it trying that instead of the odbc connection or the id & PW that gets passed in with the app? Any ideas would be most appreciated.

Am I missing some Crystal dll or SP or what? Thanks in advance.

Active Contributor
0 Kudos


You are correct that the report does not save the password. So as long as your application is logging the report onto the database it should be working.

If your report has subreports, those subreports also have to logon. Depending on the logon method you are using, you may have to loop through the subreports and log each one on individually.

What method are you using to log the report onto the database?



View Entire Topic
0 Kudos

I'm going to close this out as It's been resolved.

I previously had reentered in the passwords at various places and that failed.

Then in a moment of desperation I deleted the odbc dsn settings and started over.

Tada...that worked. Sorry to have bothered everyone with this question.