cancel
Showing results for 
Search instead for 
Did you mean: 

Outbound ZIDoc being sent by R/3 but not recieved in XI

Former Member
0 Kudos

Hi,

In my scenario, 2 IDocs are being triggered a MATMAS IDoc and a ZIDoc. The ZIDoc is triggered in the customer exit of the standard function module for MATMAS.

Once triggered, the IDoc list shows both the IDocs with Status 3. The MATMAS is received in XI; however the MONI in XI does not show any trace of the ZIDoc.

Could someone help me with this?

Thanks in advance.

Regards,

Tejal.

View Entire Topic
Former Member
0 Kudos

Hi,

Check transaction sm58 in the R/3 system.

Also recheck the partner profile settings for the zidoc.

Regards,

Smitha.

Former Member
0 Kudos

Initailly the ZIDoc was getting stuck in the queue but we manually dispatched it using the program 'rbdmoind'. Also, the partner profile settings for the ZIDoc are proper.

Former Member
0 Kudos

Hi,

Try looking for this ZIdoc in IDX5.

In case, you do not find it here, it would mean that the ZIdoc did not reach the Idoc adapter and thus XI.

Did you retrigger the idoc after executing the program rbdmoind? Did it pass through the queue successfully, without any manual intervention from your side?

What was the message that was displayed when the Idoc was stuck in Sm58, before you executed this program?

Regards,

Smitha.

Former Member
0 Kudos

The ZIDoc is not visible in IDX5. Only the standard IDoc MATMAS is seen here.

Former Member
0 Kudos

Hi,

That would mean that the Idoc did not reach XI, and is still in the R/3 system.

Recheck all the configurations in the R/3 system.

Regards,

Smitha.

Former Member
0 Kudos

please check sm58 in R/3 system their you will find the IDOC and corresponding error.their is an error so it did not reach XI. check SM58

please reward points

thanks

Sreeram.G.Reddy

Former Member
0 Kudos

Yes, right. The ZIDoc does not reach XI even when all the settings are proper. Also, there is nothing displayed in SM58 for R/3.

Former Member
0 Kudos

can u check in BD75 of R/3 system

Former Member
0 Kudos

There is no message stuck up in the queue on the R/3 side.

prabhu_s2
Active Contributor
0 Kudos

did u have a check on the conditions set in the BPM like the correlation id in each of the receviers etc. also check if the field value for the correlation field has the same value in the idoc segment....check for case sensitive also

Former Member
0 Kudos

check in

IDX5 of Xi syste you should see you IDOC.do you have meta data of ZIDOC in XI that is IDX2

prabhu_s2
Active Contributor
0 Kudos

can u check by reloading the metadata in idx1.keep posted on the results