cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle Patchset Upgrade 9.2.0.8

Former Member
0 Kudos
172

Hi Team,

I work in BW 3.5 which has the Oracle 9.2.0.7. I had tried upgrading the Patchset to 9.2.0.8 and 1) Initially when i started it went through 75% and due to lack of enough space it quit but when i checked the Patchset level it has upgraded itself to 9.2.0.8.

2) I then wanted to try reinstall and i started the RunInstaller again and it was where i has to select what i need to install and i lost the network connection.

I logged in again and when i try to run the RunInstaller command i get

"psapdb:orabwp> ./runInstaller[83]: ./runInstaller: 0403-006 Execute permission denied ".

I have the bug fixes of Oracle 9.2.0.8 which is not yet applied and when i try running that i get the below error message.

orabwp> opatch apply

Oracle Interim Patch Installer version 1.0.0.0.57

Copyright (c) 2007 Oracle Corporation. All Rights Reserved..

We recommend you refer to the OPatch documentation under

OPatch/docs for usage reference. We also recommend using

the latest OPatch version. For the latest OPatch version

and other support related issues, please refer to document

293369.1 which is viewable from metalink.oracle.com

Oracle Home : /oracle/BWP/920_64

Oracle Home Inventory : /oracle/BWP/920_64/inventory

Central Inventory : /oracle/oraInventory

from : /etc/oraInst.loc

OUI location : /oracle/BWP/920_64/oui

OUI shared library : /oracle/BWP/920_64/oui/lib/aix/liboraInstaller.so

Java location : /oracle/BWP/920_64/jre/1.4.2/bin/java

Log file location : /oracle/BWP/920_64/.patch_storage/<patch ID>/*.log

Creating log file "/oracle/BWP/920_64/.patch_storage/5496862/Apply_5496862_10-28-2007_19-16-50.log"

Invoking fuser to check for active processes.

Invoking fuser on "/oracle/BWP/920_64/bin/oracle"

OPATCH_JAVA_ERROR=Exception in CheckConflict. null

Cannot check bug/file conflict and component pre-req.

ERROR: OPatch failed during pre-reqs check.

Kindly help:)

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

....

<b><u>OPATCH_JAVA_ERROR=Exception in CheckConflict</u></b>. <b><i>null

Cannot check bug/file conflict and component pre-req.</i></b>

Inventory can be maybe corrupted.

See please the oracle Note:

<b><u>414600.1</u></b> : Opatch Lsinventory "Can not get details for given Oracle Home" error

Check please the permissions of all files and directories under <b><i>oraInventory</i></b> and <b><i>$ORACLE_HOME/inventory</i></b>.

Former Member
0 Kudos

<u><b>./runInstaller[83]: ./runInstaller: 0403-006 Execute permission denied</b></u>

<u><b><i>ERROR: OPatch failed during pre-reqs check</i></b></u>

Do you have a /<u><b>etc/oraInst.loc</b></u> which shows to the inventory of this database?

Could you call <b><i><u>opatch lsinventory</u></i></b>? You may get the same error, don't you?

could you post the environment setting of ora<sid>?

Former Member
0 Kudos

the location of the global inventory (oraInventory) is mostly to find in <b><i><u>/etc/oraInst.loc</u></i></b> on some UNIX platforms. Check please the permissions of the directories or files under <b>inventory</b> and <b>oraInventory</b>.

Former Member
0 Kudos

it is not enough to upgrade the patchset 9.2.0.7 to 9.2.0.8, you should also upgrade the database to new patchset.

like that:

1) Upgrade the patchset to 9.2.0.8 see sap note: <b><u>539921</u></b> - Current patch set for Oracle 9.2.0

2) apply important patches

3) upgrade the database

After database upgrade, your database and the software should have the same version:

<b><i>select version from v$instance</i></b>; (software version)

<i><b>select comp_id,version,status from dba_registry</b></i>;</i> (database version)

fidel_vales
Employee
Employee
0 Kudos

@Baran

????????

sorry, can you repeat it?:

<quote>

<b>it is not enough to upgrade the patchset 9.2.0.7 to 9.2.0.8, you should also upgrade the database to new patchset.</b>

</quote>

Have you read what are you writing?

@Priyanka Singh,

You have the DB software in an inconsistent state. The best you can do is to deinstall the oracle software and reinstall it ( 9i base and the patchset 9.2.0.8 )

Former Member
0 Kudos

Hello Fidel,

I mean that the database and the software should have the same version.

If he upgraded the patchset from 9.2.0.7 to 9.2.0.8, the database should also have the same version, also 9.2.0.8.

Best regards

Baran

Former Member
0 Kudos

Hello Fidel,

of course not yet. I meant, after solving the problems regarding patchset, then the database should show the same version like the database software version.

I think also that his DB software is in an inconsistent state. INventory is maybe corrupted.

Best regards

Baran

Former Member
0 Kudos

Hello Fidel,

if everything is done according to the README of the patchset, then the database will have also the same version like the database software version. And after that the interim patches can be applied.

I meant that. You have maybe missunderstood me.

Best regards

Baran

Former Member
0 Kudos

Hi Team,

I really thank u all for giving ur valuable thoughts. I have below listed the Output of all the files which is discussed below to give a clear idea of what is wrong.

<u><b>VERSION IN SOFTWARE AND REGISTRY</b></u>

orabwp> sqlplus /nolog

SQL*Plus: Release 9.2.0.8.0 - Production on Mon Oct 29 04:46:13 2007

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

SQL> conn /as sysdba

Connected.

SQL> select version from v$instance;

VERSION

-


9.2.0.8.0

SQL> select comp_id,version,status from dba_registry;

COMP_ID VERSION STATUS

-


-


-


CATALOG 9.2.0.8.0 VALID

CATPROC 9.2.0.8.0 VALID

<u><b>OUTPUT OF /ETC/ORAINST.LOC</b></u>

orabwp> more /etc/oraInst.loc

inventory_loc=/oracle/oraInventory

inst_group=dba

<b><u>ERROR OF OPATCH LSINVENTORY</u></b>

orabwp> opatch lsinventory

Oracle Interim Patch Installer version 1.0.0.0.57

Copyright (c) 2007 Oracle Corporation. All Rights Reserved..

We recommend you refer to the OPatch documentation under

OPatch/docs for usage reference. We also recommend using

the latest OPatch version. For the latest OPatch version

and other support related issues, please refer to document

293369.1 which is viewable from metalink.oracle.com

Oracle Home : /oracle/BWP/920_64

Oracle Home Inventory : /oracle/BWP/920_64/inventory

Central Inventory : /oracle/oraInventory

from : /etc/oraInst.loc

OUI location : /oracle/BWP/920_64/oui

OUI shared library : /oracle/BWP/920_64/oui/lib/aix/liboraInstaller.so

Java location : /oracle/BWP/920_64/jre/1.4.2/bin/java

Log file location : /oracle/BWP/920_64/.patch_storage/<patch ID>/*.log

Creating log file "/oracle/BWP/920_64/.patch_storage/LsInventory__10-29-2007_05-06-43.log"

Result:

OPATCH_JAVA_ERROR : An exception of type "Exception" has occurred:

null

There is no Interim Patch

OPATCH_JAVA_ERROR : An exception of type "Exception" has occurred:

Can not get a list of inventory on this home.

ERROR: OPatch failed because of Inventory problem.

<b><u>ENVIRONMENT OF ORASID</u></b>

orabwp> env

_=/usr/bin/env

MANPATH=/usr/share/man/en_US

LANG=en_US

THREAD=NOPS

LOGIN=orabwp

ORACLE_PSRV=BWP

PATH=/oracle/BWP/920_64/bin:/home/orabwp:/usr/sap/BWP/SYS/exe/runU:/usr/sap/BWP/SYS/exe/run:/usr/bin:/etc:/usr/sbin:/usr/ucb:/home/orabwp/bin:/usr/bin/X11:/sbin:.:/oracle/BWP/920_64/OPatch

NLS_LANG=AMERICAN_AMERICA.UTF8

PPO_ENV_FILE=/usr/lpp/pd/bin/ppo.env

ORACLE_BASE=/oracle

LC__FASTMSG=true

LOGNAME=orabwp

PDBASE=/var/pd

MAIL=/usr/spool/mail/orabwp

dbs_ora_tnsname=BWP

ORACLE_SID=BWP

LOCPATH=/usr/lib/nls/loc

PS1=

orabwp>

DB_SID=BWP

DIR_LIBRARY=/usr/sap/BWP/SYS/exe/run

USER=orabwp

AUTHSTATE=compat

dbs_ora_schema=SAPBWP

SHELL=/usr/bin/ksh

ODMDIR=/etc/objrepos

SAPDATA_HOME=/oracle/BWP

ORA_NLS33=/oracle/BWP/920_64/ocommon/nls/admin/data

HOME=/home/orabwp

TERM=xterm

MAILMSG=[YOU HAVE NEW MAIL]

ORACLE_HOME=/oracle/BWP/920_64

PWD=/home/orabwp

TZ=GMT0

dbms_type=ORA

SAPSYSTEMNAME=BWP

A__z=! LOGNAME

NLSPATH=/usr/lib/nls/msg/%L/%N:/usr/lib/nls/msg/%L/%N.cat

LIBPATH=/usr/lib:/lib:/usr/sap/BWP/SYS/exe/run:/usr/sap/BWP/SYS/exe/runU

<b><u>PERMISSION OF INVENTORY AND ORAINVENTORY</u></b>

drwxr-xr-x 13 orabwp dba 4096 Oct 28 02:32 inventory

drwxrwsr-x 13 orasjp dba 4096 Oct 28 19:16 oraInventory

<u></u>

Former Member
0 Kudos

Hello Priyanka,

did you solve your problem? If not, let us know.

I see you have another database called SJP on this host. Which version does this database have? SAP suggests to use different inventory for every database.

I see that the databases SJP and BWP use the same. It is suggested to have

separate inventories.

drwxr-xr-x 13 ora<b><u>bwp</u></b> dba 4096 Oct 28 02:32 inventory

drwxrwsr-x 13 ora<b><u>sjp</u></b> dba 4096 Oct 28 19:16 <b><u>oraInventory</u></b>

more /etc/<b><u>oraInst.loc</u></b>

inventory_loc<b><u>=/oracle/oraInventory</u></b>

See please following SAP notes:

<b><u>350251</u></b> - Creating a New or 2nd Oracle SID with runInstaller (this note ist very<u> important</u>)

<b><u>98252</u></b> - Installing two Oracle databases on a host

see also this thread:

Best regards

Baran

george_hamilton
Participant
0 Kudos

Where are the important patches after the installation of the 9.2.0.8 patchset listed? Is it patch 12 as listed in note 539921 for Windows i386?

Former Member
0 Kudos

see please the sap note: 938986 - Oracle Database 9.2: Patches for 9.2.0 for UNIX Platforms and the sap note 539921 for current oracle 9.2. patchset and mini patches for windows.

Former Member
0 Kudos

In which OS do you try to install Oracle database software?

see please the following SAP note:

<b><u>640910</u></b> - Problems when using OPatch

Regards

Baran