cancel
Showing results for 
Search instead for 
Did you mean: 

Open "Related Links" in the portal content area

Former Member
0 Kudos

Hi,

How can I open the links of the "Related Links iView" in the Portal Content Area, not in Popped up window?

We are using EP SP10.

I'd appreciate any helps.

Best Regards,

Nash

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

hi nakagawa,

i think there is some level that you have to set in the XML file...

i am not sure about that.

regards,

purushothaman.

Former Member
0 Kudos

Hi There,

Did you set the <b>Isolation Method</b> of the corresponding page to <b>URL</b>?

Regards,

SK.

Former Member
0 Kudos

Hi SK,

Thanks for your reply.

There is no <b>Isolation Method</b> property in the assigned iviews as related links. I am not sure if I get you right....

Best Regards,

Nash

Former Member
0 Kudos

Hi Nash,

Sorry about that! I was thinking in another way.

Anyways, it seems, Whether a related link opens in a new window or not is determined by the 'Launch in New Window' property of the related link object. It should be 'Display in Content Area'.

When you add an iView/page as a related link, the value for this delta link changes to 'Display in Separate Window' (Whatever may be the value for this property in the original source iView).

Check the following link out: It might be helpful to you:

In this link, Daniel tells for an SP13 portal. I am not sure about SP10.

Please try and let me know.

Regards,

SK.

Former Member
0 Kudos

Hi SK,

Thank you for takin your time.

I checked the 'Display in Content Area' property and made sure it was set to 'Display in Content Area'.

Actually that property of the iview assigned as a related link was already set to 'Display in Content Area' which means I didn't have to change it. Something might be defferent between those SPs.

I also modified related link par and found whether new window or content depends on that propery as you said.

I tested the code and weired things is getShowType() always returns "1" , doesn't change depending on the propery unfortunatelly.

Maybe something is missing...

I'll doublecheck it next week.

Have a nice weekend.

Rgds,

Nash

Former Member
0 Kudos

I sent a OSS messagge and got a reply from SAP.

They answered that related links are always shown in the new window.

just FYI

sigh...

Nash

Dan_Wroblewski
Developer Advocate
Developer Advocate
0 Kudos

Hi Nash,

It is NOT true that Related Links always open in a new window.

It is very important to know where to change the Launch in New Window property.

Let's say I have a role R1, with W1, with I1, and I1 has a related link to I2. You need to do the following:

  • Open W1.

  • Select I1 and open for editing.

  • Set the Display to Related Links. This screen shows the iView that is the related link (I2).

  • Select I2 and click Edit.

  • Change Launch in New Window to Display in Content Area.

For some reason, when you select an iView to be a related link, this property is changed in the related item delta link. This seems like a bug.

You cannot change the property in the original iView.

NOTE: The above is for SP13. There may be some differences between SPs, but my assumption is that they work the same.

Hope this helps.

Daniel

Former Member
0 Kudos

Hi Daniel,

I did it in exaclty the same way as you described here.

But had no luck.

What's different from your situation were ..

1) I tried that on SP10

2) "Launch in New Window" was ALREADY set to "Display in Content Area" when I got to the delta-linked relatedlink iview properties from the W1.

I am afraid upgrading our SP only solve this issue...

Thanks&Regards,

Nash

Former Member
0 Kudos

Upgrading to SP14 solved this problem.

Thanks

Nash