cancel
Showing results for 
Search instead for 
Did you mean: 

Old Instances Persisting in SAP Build Process Visibility Scenario After Redeployment

FDann
Explorer
0 Kudos
258

Hello,

Recently, I encountered a backend issue in my workflow within SAP Build Process Automation, which caused many instances to crash. After resolving the problem and redeploying the process, the old instances are still visible in the process visibility scenario, rendering it ineffective.

I've tried several solutions, including:

  • Deleting all "older" released versions of the process
  • Redeploying the process visibility scenario
  • Clearing the processed data in the monitoring settings of the SAP Build lobby

Despite these efforts, the old instances always reappear after processing new data. They are no longer visible in the monitoring of the process/workflow itself, yet they persist in the visibility scenario.

Does anyone have any hints on how to fix this?

Thank you!

View Entire Topic
SandhyaG
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi, please Undeploy the deployed version of your project which will remove all the data existing until that point of time.  You can then redeploy the project again 

 

thanks

FDann
Explorer
0 Kudos

Hi, I undeployed again, waited for a bit, and then redeployed, but the same old process instances keep appearing. I even cleared the processed data in the monitoring tab, but it didn't help.

SandhyaG
Product and Topic Expert
Product and Topic Expert
Hi, For the instances to not show up, the events should be deleted. Undeploy will take care of deleting the events but may not happen immediately as a scheduled job takes care of this in the background. What you can do to get rid of the older data is to go to Acquired Events application in Monitor tab. Apply the filter and search for all events with the process definition ID that is defined in the scenario model. Click on delete. Now in Manage Visibility scenarios, clear process data. With this , all data acquired so far will be removed. Hope this helps.
FDann
Explorer
0 Kudos
That seems like progress, but unfortunately, after deleting all events, it says "events are deleted successfully." Then, upon refreshing, all the events reappear. I've tried this both when the process is deployed and undeployed.
SandhyaG
Product and Topic Expert
Product and Topic Expert
0 Kudos
Hi, Can you setup a call with me and we could look into this ? Alternatively, you could raise a ticket on LOD-BPM-VIS component
FDann
Explorer
0 Kudos
Thanks for resolving the issue together with me. For anyone else with the same problem: you need to filter with the whole process definition id (including all prefixes and region) to be able to delete the events. The filter will work with only the process name, but you will not be able to delete the events. This fixed the issue for me, thanks for the help.