cancel
Showing results for 
Search instead for 
Did you mean: 

ODS does not activate 0 record data load in Process Chain

Former Member
0 Kudos

Hi,

I have a Proces Chain to delta load ODS data. If there is no data extracted, the data package is not activated. In the next data load cycle, even with data, the data package will not activate due to previous package was not activate yet. Does any one know how to force activate package in process chain even no data extracted.

Thanks,

Frank

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Jita and Arun,

Thanks so much for your quick response. I do have a separate step in the process chain to activate ODS. The problem is the activation process did not get executed. The Load Data step is stay in yellow, not complete, even I set the Time Out time to small number, 1 minute, and Treatment of Warning to Green Light. The Load Step seams never complete when there is no data extracted. Is there any way to make it moving forward even there is no data?

Thanks,

Frank

Former Member
0 Kudos

Hi Frank,

I think what you can do is the following:

Goto the request monitor. Goto the details of your yellow request. Now in the top menu click on Settings->Evaluation of requests. In the following popup judge the request to successful if no data is available in the system.

This is a global setting and will work for all requests.

regards

Siggi

Former Member
0 Kudos

Hi Siggi,

Thanks a lot for your help. Your suggestion works great.

Regards,

Frank

Former Member
0 Kudos

Hi Frank,

if it solved your issue, it would be great if you assign some points. It is the way to say thanks to the guys that help you.

Siggi

Former Member
0 Kudos

Hi,

You need to use the Process type "Activate ODS Object Data" under Data Target Administration to serperately activate the data in the activation queue after the process step Execute InfoPackage of your ODS.

Thank you

Arun

Former Member
0 Kudos

Frank

Do you activate separately after the load. I have a process chain in which I activate after the load. We get no data on Sundays and yet our loads are working and activating correctly.

You possibly are expecting the ODS to activate automatically because of the setting on the ODS. However, this does not work in a process chain. You have to put in a step for the activation.

Hope this helps.

Jita