cancel
Showing results for 
Search instead for 
Did you mean: 

ODS Activation error

former_member355937
Participant
0 Kudos

Hi Gurus,

We are encountering an ODS activation problem.

We are trying to manually activate a request in the ODS.

When we click on the activate button, it runs for a very long time.

We are loading a data from a Flat file and from another cube to this ODS. Then eventually, it will be loaded to another infocube.

These are the things we tried to do:

1) SM12 - We saw a lock in RSICCONT table

2) Tried to delete this lock and repeat the process but error still happens.

These are the things we did before this activation problem occured:

1) There are some erroneous requests in the ODS caused by "Inconsistent aggregation behavior) -- trying to activate a delta and a full request at the same time.

2) We deleted those erroneous requests from the tables: RSICCONT, RSMONICDP and RSODSACTREQ. After that, all the tables consistently contains the same correct requests.

3) We ran RSRV to check the status of the activation program and it is now OK.

4) We tried to re-init the Cube where this ODS goes to (ZIC_ZZZ). Reint was successful.

Now, we still could not reload these request to the said ODS.

Can anyone help us on this?

Thanks a lot!

Jeffrey

View Entire Topic
mr_v
Active Contributor
0 Kudos

If the load is succeeful and issue is only with activation, just give a try with following.

Select DSO -> Activate Data

From the next screen select the request, and click "Activate in Parallel" button.

From the next screen, select "Dialog" radio button, and select "PARALLEL_GENERATORS".

No of Processes: __ try with 1, if that does not work then try with 2, otherwise 3

(because totally depends on u r server configuration. Couple of months ago, I faced the same issue. First I tried with 3, then with 2..Finally DSO got activated with 1).