cancel
Showing results for 
Search instead for 
Did you mean: 

OBN - Unable to add iview to operation

s0004895470
Active Participant
0 Kudos

Dear portal experts,

I'm experiencing problems when adding a custom iview to an operation on a existing business object.

The operation is called from a web dynpro application with POWL using launchpad (R/3 transaction LPD_CUST).

Calling the operation is not an issue. I get the popup in the portal saying that no iview is linked to this operation.

I have full permission on both folders in the PCD.

When I go to the business object in the PCD, I select the operation and navigate to my custom iview in the content tree. I get the action "Add iview to operation" in the context menu for the iview. So far so good.

When I execute the operation, nothing happens. When I retrieve the list of iviews that are linked to my operation, nothing is found.

I have tried to do the same for other iviews/operations, but nothing seems to work.

Do any of you have experienced and/or fixed this before?

thanks in advance!

Best regards,

Luk

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

If adding iview to operation doesnt work, try to add operation to iview.

Open iview, from drop down select Object-Based Navigation and then right click on operation from content tree.

Its a straight forward approach in either way you do it.

Also make sure this iview is attached to a role and that role is assigned to you. Else you will see that iview not defined for operation.

Regards,

Nag

s0004895470
Active Participant
0 Kudos

Hi Nag,

Thanks for your suggestion, but that's not working out either. There is no action available on the operation when I open the obn page from the tree.

Any other suggestions?

Kind regards,

Luk

Answers (0)