cancel
Showing results for 
Search instead for 
Did you mean: 

NWDS Windows 7 problem - XP dll not working

former_member190457
Contributor
0 Kudos
43

Hi developers,

I am experiencing problems when installing NWDS 7.11 SP6 on my Windows 7 laptop (64 bit OS).

I have installed Jdk 1.5 (32 bit) as this proved the only working version: the 64 bit Jdk would cause Eclipse to crash at startup.

I have then unzipped the NWDS platform, selected the 32 bit jdk and started downloading the SP6 plugins from swdc.

What happens is that when starting NWDS no-one of the SAP perspectives (WDJ, CAF, whatever) is available.

In the logs I can see several errors like:


!MESSAGE Could not install bundle <name_of_the_bundle>
No Bundle-NativeCode match

This is probably related to .dll not working on Win7

I know of other developers having the same error, can anyone please shed some light?

Thanks, regards

Vincenzo

Accepted Solutions (1)

Accepted Solutions (1)

ErvinSzolke
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Vincenzo.,

that note is an internally released note.

Best Regards,

Ervin

former_member190457
Contributor
0 Kudos

Ok, I agree, no official support for this workaround

Thanks, regards

Vincenzo

Answers (3)

Answers (3)

ErvinSzolke
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi,

yes, the current official solution is to have a constellation which is supported as per the PAM.

Best Regards,

Ervin

ErvinSzolke
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Vincenzo,

yes, but please notice that this workaround is officially not supported, you can use it on your own risk.

See also:

Best Regards,

Ervin

former_member190457
Contributor
0 Kudos

Hi Ervin,

I would say that this workaround is official as you can read from note 1299077

Please correct me if I'm getting it wrong

Thanks, regards

Vincenzo

ErvinSzolke
Product and Topic Expert
Product and Topic Expert
0 Kudos
former_member190457
Contributor
0 Kudos

Hi, thanks for replying

Actually no NWDS version exists for 64 bit OS

The only way to have it working on win vista or 7 is to append the following lines to file eclipse/SapNetweaverDeveloperStudio.ini

-Dos.name=Windows XP

-Dos.version=5.1

This must be done before installing the plugins

Thanks, regards

Vincenzo