cancel
Showing results for 
Search instead for 
Did you mean: 

NWDS: Start Debugging for J2EE Application

Former Member
0 Kudos
69

Hi,

I followed all the steps in order to create at NWDS a new Web Module Project -> generate a WAR file and then create an Enterprise Application Project (connect it with the Web module Project) and finally generate an EAR file. The trouble starts when i try to debug a JSP page (from the Web Module Project). Thus, when i go to Run->Debug->Create a new J2EE Application, although i can choose the J2EE engine instance (which is already running), when i try to choose the Enterprise Application Project from <<Browse ...>> button i can't see the Enterprise Project that i have in the J2EE Explorer! So, i can't start debugging!

The documentation at http://help.sap.com/saphelp_webas630/helpdata/en/63/b9d45d9d8d0f46a7618d8c3681de89/content.htm refers to another version of NWDS because i can't see in my version (2.0.11) the option SAP J2EE Engine Debug (under the Run->Debug window).

I use Netweaver Developer Studio Version: 2.0.11 and I'm connected to J2EE Engine with server status Debug Mode=ON.

Regards,

Thanassis

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

Have you checked the compile settings in your project?

Check the Classfile generation settings, maybe it helps.

Success,

Roelof

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi,

I am also facing the same issue. Could anybody please clarify the issue?

Former Member
0 Kudos

Hi,

Create an EAR Module and add you WAR file to the EAR and see if you are able to get it displayed.

i really havent tried this and i see it will work if deployed as an EAR.

Regards,

S.Divakar

Former Member
0 Kudos

Hi Salla,

I have already created a EAR module and deployed it.. so as you understand the ear file is created and includes the war fileother xml files. Also i deploy the ear file to server... so i can create the site (with full folderfiles structure) to the J2EE server...but the debugging process is still not available

Regards,

Thanassis