Showing results for 
Search instead for 
Did you mean: 

NWDS installation Fails on Windows 8 64 bit Machine.

Former Member
0 Kudos


I have got below nwds version from my admin and tried to install in windows 8 64 bit machine


(01) I do not have any idea about this version is this 7.3 or Higher ?

(02) Tried to install this using jdk 7 32 bit version. But it gives below error

Failed to load JNI shared library c:\..\..\jvm.dll

Next  i tried with jdk 1.7 64 bit version , it loads the application , but after loading , it gives java Majorminor version Exception.

Appreciate any help on this.

Accepted Solutions (0)

Answers (1)

Answers (1)

Active Contributor
0 Kudos

Hi Anura!

Use 64 bit java 6 jdk.

Regards, Evgeniy.

Former Member
0 Kudos

Hi Evgeniy,

Thanks for the quick reply. I think this nwds is 32 bit and also need java 7 according to the eclipse.ini file.

I tried with 64 bit java 6 , but eclipse(nwds) load failed with below error log.

!SESSION 2016-06-14 18:58:20.568 -----------------------------------------------



java.vendor=Sun Microsystems Inc.

BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US

Framework arguments:  -product org.eclipse.epp.package.jee.product

Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product

!ENTRY org.eclipse.ant.core 4 0 2016-06-14 18:58:30.103

!MESSAGE FrameworkEvent ERROR


org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ant.core [78]

  Unresolved requirement: Require-Bundle: org.eclipse.core.variables; bundle-version="[3.1.0,4.0.0)"

    -> Bundle-SymbolicName: org.eclipse.core.variables; bundle-version="3.2.800.v20130819-1716"; singleton:="true"

       org.eclipse.core.variables [107]

         Unresolved requirement: Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.3.0,4.0.0)"

           -> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150405-1723"; singleton:="true"

              org.eclipse.core.runtime [104]

                Unresolved requirement: Require-Bundle:; bundle-version="[3.2.0,4.0.0)"; visibility:="reexport"

                  -> Bundle-SymbolicName:; bundle-version="3.7.0.v20150330-2103"; singleton:="true"


                       Unresolved requirement: Require-Capability:; filter:="(&("


Active Contributor
0 Kudos

Hello Anura,

If am not wrong NWDS doesn't require any installation.

You can download the zipped file and extract and use it.

Active Contributor
0 Kudos

Hi Anura!

I have NWDS version 8.31.170006.160226113552 (SAP NetWeaver Developer Studio

SAP Enhancement Package 1 for SAP NetWeaver Developer Studio 7.3 SP17 PAT0006) and it runs on Java SE JDK 1.6.0_37 64bit.

Former Member
0 Kudos

Hi Evgeniy,

I could managed to install NWDS nwds-extsoa-7.3-EHP1-SP18-PAT0001-win32 using SAP JDK 32 bit version. But Compiled Java Mapping files is not working in PI using this 32 bit version Of SAP JDK.

So needs to move on to 64 bit version. I will try with your NWDS and JDK versions and let you know the status . Thanks for the info.