cancel
Showing results for 
Search instead for 
Did you mean: 

NWBC for HTML autologout

Former Member
0 Kudos
1,360

Hi everybody,

we would like to use NWBC for HTML. Amongst our users are many nurses. About 10-15 nurses share a single workstation.

When they are in a hurry they will forget to logout.

Is it possible to automatically logout after e.g. 15 min of inactivity?

TIA,

Thomas

Accepted Solutions (0)

Answers (5)

Answers (5)

devender_goyal2
Explorer
0 Kudos

Hello All,

NWBC for HTML timeout can be set using the below parameters:

set the system to create assertion tickets by using the below parameter:

login/create_sso2_ticket = 3

time out value can be controlled by using the below parameter:

http/security_session_timeout = 60 - 100000


hope it helps.


Regards,

Devender Goyal




devender_goyal2
Explorer
0 Kudos

Hi Thomas,

Did you find the solution. i have the similar situation for kiosks where multiple users uses the same Kiosk. and auto log out is must.

Any help will be highly appreciated.

Thanks,

Devender.

devender_goyal2
Explorer
0 Kudos

I have set up the below parameters but didn’t help, NWBC(HTML) still doesn’t log out after 60 secs

rdisp/gui_auto_logout= 1800
rdisp/plugin_auto_logout: 30

rdisp/keepalive_timeout: 60   

rdisp/keepalive.=30

icm/HTTP/client/keep_alive_timeout=10

http/security_session_timeout=60

icm/keep_alive_timeout=30

icm/server_port_0 = PROT=HTTP,PORT=80$$,TIMEOUT=30,PROCTIMEOUT=900

Setup the session parameter

In SICF> service maintained session timeout as well

PatL
Explorer
0 Kudos

Hi Devender

you have to set a Parameter in the "Nwbc.Options.xml" file ( works with NWBC for Desktop)

<SingleOptions>

  <IdleTimeout>60</IdleTimeout>

regards

Patrick

devender_goyal2
Explorer
0 Kudos

Where can i find this file "Nwbc.Options.xml".

Former Member
0 Kudos

Hi Devander,

You will find it under c:\users\<username>\appdata\roaming\sap\nwbc

the <username> is the windows user, who is logged into the system.

devender_goyal2
Explorer
0 Kudos

Thanks Jakob,

My NWBC desktop client has some issues connecting to the system, but I need this for NWBC for HTML.

Regards,

Devender.


former_member183060
Contributor
0 Kudos

Hello Guys,

rdisp/gui_auto_logout will not affect NWBC, and will not affect HTTP, as it is for GUI sessions only.

Parameret icm/server_port_0 can help, and also check http/security_session_timeout.

rdisp/plugin_auto_logout affects the session context.

This note can alo help:

1811778 - TIMEOUT of server port does not override global parameter icm/keep_alive_timeout

Regards

Melinda

Former Member
0 Kudos

Hi Melinda,

Thank you for the note. But i would really appreciate if you can clarify the following point from sap note 705013-Timeout for ICF services based on ITS

"

If the parameter rdisp/gui_auto_logout is set, so this

    timeout also applies to all HTTP sessions in addition to the GUI sessions."



Since NWBC for html sessions are either HTTP or HTTPS does above parameter not applicable ?

Regards

Raj

former_member183060
Contributor
0 Kudos

Hello Raj,

It depends I think. This note is for ITS so when ITS is involved then it may be applicable, but when only WebDynpro used then it is not applicable.

Regards

Melinda

Former Member
0 Kudos

This message was moderated.

Former Member
0 Kudos

Hi Thomas,

Iam also working on similar situation. Iam trying to find a parameter that sticks user to same application server after logging in with out switching between the app's servers when ever user types a new transaction or refresh the screen and asks to login again.

the session timeout from the  above  screen shot is what iam looking at and it might be suitable for me and not for your problem..

Coming to your problem check the following parameters are set in your RZ10

Kernel parameter:    rdisp/gui_auto_logout--If this is set this will work for NWBC for html as well

Kernel parameter:    rdisp/plugin_auto_logout.. you can use this parameter to set time out value exclusively to NWBC


For more information refer to

705013 - Timeout for ICF services based on ITS


Regards

Raj

ramakrishnappa
Active Contributor
0 Kudos

Hi Thomas,

You can set the session time out of 15 min for service NWBC in SICF t-code as below.

Hope this helps you.

Regards,

Rama

Former Member
0 Kudos

Thanks for the quick reply.

I set the timeout to 2 minutes to test the behavior.

Unfortunately this doesn't seem to work. Even after 10 minutes of inactivity I can work on without logging in again.

Am I missing something here?

Cheers,

Thomas

Former Member
0 Kudos

Hi ,

One thing you should consider is that if your system is set to issue SAP Logon Tickets then all these settings are sort of meaningless, and really the lifetime of the SAP Logon Ticket is more important. The client will send the SAP Logon Ticket with each HTTP request so even if your session has expired it will ask you to re-authenticate but if your Logon Ticket is still valid then you will get straight back in regardless, so from the user perspective they see no timeout.

This may explain what you are seeing, obviously I don't know how your system is configured so this might not be the issue, but wanted to mention it here in case it helps someone.

Thanks Simon

(cc Former Member)