Showing results for 
Search instead for 
Did you mean: 

npm install throws error and "0 matching services found" error in CAP project created on BAS

0 Kudos

Hi ,
I had been using Business Application Studio for like 5 months now to create CAP projects.
From around the last week of January, I am facing issues while doing the "npm install" in my CAP project.

npm install command throws error after binding the application with the HANA trial instance and making the changes in package.json file of root that includes the db kind as hana. (I have attached the code snippet and the error message below) .Other than the following change,I have not made any changes in package.json file of the root project.

The error message I get is as follows:

The node_modules folder is getting generated even though I get this error. So I proceeded with "cds watch" . Then i get the error "0 matching services found" when I click on the exposed entities . (The data model and the csv files were successfully deployed in the HDI container and in run config I did the binding to hana instance and no errors there)

The error message in the terminal is shown below:

So these issues I was not facing previously while creating and running a CAP Application. Is there any changes in config files to be done here?
Any inputs here would be very helpful.

Thanks and regards,

View Entire Topic

This is a known issue with sqlite 5.0.1, which is broken. Please fix with

npm install -D sqlite3@5.0.0

Hope this helps.

Pro tip: when talking about error messages and logs, always include the actual text instead of a screenshot.

0 Kudos

Hi Georgi,
Thanks for the solution.I tried the version you suggested. It helped. Now I do not get the error in npm install.

However when I bind my service to the HANA instance and run "cds watch" I am still getting the "0 matching services found" error message.
Can you suggest anything here?
the error log is pasted below

[cds] - server listening on { url: 'http://localhost:4004' }
[ terminate with ^C ]

[cds] - GET /catalog/Books
[2021-02-03T05:00:16.389Z | ERROR | 1903861]: { VError: Found 0 matching services
    at Object.serviceCredentials (/home/user/projects/central-launchpad-cap/node_modules/@sap/xsenv/lib/xsservices.js:109:11)
    at singleTenantInstanceManager (/home/user/projects/central-launchpad-cap/node_modules/@sap/cds-runtime/lib/hana/pool.js:35:58)
    at credentials4 (/home/user/projects/central-launchpad-cap/node_modules/@sap/cds-runtime/lib/hana/pool.js:52:85)
    at pools.set.Promise (/home/user/projects/central-launchpad-cap/node_modules/@sap/cds-runtime/lib/hana/pool.js:136:9)
    at new Promise (<anonymous>)
    at pool4 (/home/user/projects/central-launchpad-cap/node_modules/@sap/cds-runtime/lib/hana/pool.js:135:7)
    at Object.acquire (/home/user/projects/central-launchpad-cap/node_modules/@sap/cds-runtime/lib/hana/pool.js:160:12)
    at HanaDatabase.acquire (/home/user/projects/central-launchpad-cap/node_modules/@sap/cds-runtime/lib/hana/Service.js:128:28)
    at HanaDatabase.begin (/home/user/projects/central-launchpad-cap/node_modules/@sap/cds-runtime/lib/db/Service.js:53:29)
    at HanaDatabase.start (/home/user/projects/central-launchpad-cap/node_modules/@sap/cds/lib/srv/Transaction.js:66:42) jse_shortmsg: 'Found 0 matching services', jse_info: {}, message: 'Found 0 matching services' }



Hi Vishali,

Your environment is not set up correctly. Locally, you need a default-env.json that mocks the CF environment. Please consult the xsenv documentation.


0 Kudos

Thanks Sebastian. It worked after I created the default-env.json file in my project root.