cancel
Showing results for 
Search instead for 
Did you mean: 

Not able to see any nodes in the management console

Former Member
0 Kudos
201

Hi,

I installed WAS 6.40 sp9 recently and on that I installed EP6 SP9.I even installed KMC and TREX .Every thing was done successfully.But now I just tried to restart the j2ee server.Through SAP MMC I want to start but to my surprise there are no nodes in that to start the server.Did any body encounter this problem?If so please help me to resolve this issue.

Or <b>Can any one tell me how to start the j2ee server with out using SAP MMC?</b>

Regards,

Santhosh

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

you can add the systems manually afterwards. registering this dll is a prerequisite for seeing them again.

just click on properties ( at this sap systems folder ) and then you can add the systems again manually:

pattern:

<SID>

hostname <XX>

XX = instancenumber

i did it like this and it worked. ok i admit i reinstalled the central instance of the deinstalled system first. before i did it i just ran into a strange c++ error (which can have something to do with the fact that the system unregisters shared dlls of the mmc. i don t know. anyway it works now.

tahran_celik
Explorer
0 Kudos

Hi Santhosh,

please try to reregister the sapmmc.dll with the following command in the c:\windows\system32 directory.

Open a command prompt and execute regsvr32 sapmmc.dll .

The the nodes should appear inside the MMC console.

Regards

Tahran

Former Member
0 Kudos

Hi All,

As mentioned by Tahran to reregister the sapmmc.dll,in the command prompt,I executed the command <b>regsvr32 sapmmc.dll</b>

It gave an alert successfully registered.

But now also I am not able to see the nodes in Management Console.I checked in services that all services are running fine.

one more thing I could start the j2e server and sdm through command prompt.And portal is also running fine.

Only thing is,I am not able to see nodes in management console

Can any one help me in this regard.

Thanks in Advance,

Santhosh

Vlado
Advisor
Advisor
0 Kudos

Hi Santhosh,

> Through SAP MMC I

> want to start but to my surprise there are no nodes

> in that to start the server.

Probably the Windows services are not started. Go to Control Panel -> Administrative Tools -> Services and check if both SAP<SID>_<number> services are started.

> Or <b>Can any one tell me how to start the j2ee

> server with out using SAP MMC?</b>

Go to /usr/sap/<SID>/<INSTANCE>/j2ee/os_libs and execute the following command:

jcontrol -bootstrap=yes pf=/usr/sap/<SID>/SYS/profile/<SID>_<INSTANCE>_<host> -startMode=console

Hope this helps,

Vladimir