cancel
Showing results for 
Search instead for 
Did you mean: 

Non-capital letters in selection criteria

Former Member
0 Kudos

hi,

in infopackage, in selection criteria I want to choose 'j' but not 'J' but system changes it to capital letter in IDoc.

Does somebody knows how to deal with this?

Regards,

Andrzej

Accepted Solutions (1)

Accepted Solutions (1)

edwin_harpino
Active Contributor
0 Kudos

hi Andrzej,

i think it's the 'behaviour', the infoobject has 'lower case letters' marked ? or 'attribute only' ?

not sure can be done with following, try if start routine in transfer rules can achieve

delete datapak where [fieldname for that selection] <> 'j'

or infopackage routine

or there is simple way ?

hope this helps.

data: l_idx like sy-tabix.

read table l_t_range with key

fieldname = '[your field name for selection]'.

l_idx = sy-tabix.

*....

DELETE l_t_range

WHERE iobjnm = '[your infoobject name]'

and fieldname = '[your field name for selection]'.

L_t_RANGE-SIGN = 'I'.

L_t_RANGE-OPTION = 'EQ'.

L_t_RANGE-LOW = 'j'.

append l_t_range.

modify l_t_range index l_idx.

p_subrc = 0.

$$ end of routine - insert your code only before this line -

endform

Former Member
0 Kudos

hi,

your code was almost ok. I used this:

data: l_idx like sy-tabix.

read table l_t_range with key

fieldname = 'VBTYP_N'.

l_idx = sy-tabix.

  • DELETE l_t_range

  • WHERE fieldname = 'VBTYP_N'.

L_t_RANGE-SIGN = 'I'.

L_t_RANGE-OPTION = 'EQ'.

L_t_RANGE-LOW = 'h'.

  • append l_t_range.

modify l_t_range index l_idx.

p_subrc = 0.

thanks

Andrzej

Message was edited by: Aksik

Answers (0)