cancel
Showing results for 
Search instead for 
Did you mean: 

New BEx query generation error

Former Member
0 Kudos

Hi everyone.

I have upgraded from BW 3.1 to 3.5 and I am facing some error messages when attempting to create BEx queries from InfoProviders (that are good and loaded with data).

When click the "new query" icon from the BEx GUI I receive the following error/warning message:

"Internal error when generating the history. Use a different view"

Then, when clicking "OK" and when I proceed to select an InfoProvider for my query I receive the following fatal error message:

"Run Time Error 91: Object variable or With block variable not set". BEx then terminates.

Any comments or suggestions to these issues? Any feedback would be highly appreciated.

Regards

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Martin,

Welcome to SDN!

Looks like GUI was installed wrongly (or version with bugs was used). Try to reinstall the last version.

Best regards,

Eugene

Answers (1)

Answers (1)

0 Kudos

hi, you may need to install/apply BW 3.5 front-end patches,

transaction rs_pers_activate is used to activate BEx history but this is usually use when upgrade from 2.x to 3.x, tick 'Activate BEx history' then execute.