cancel
Showing results for 
Search instead for 
Did you mean: 

NetWeaver Developer Studio startup problem

sarat_addanki2
Explorer
0 Kudos
379

Hi,

Successfully installed WAS 6.30.

But while starting NetWeaver Developer Studio , getting the following error message and studio is not started

Sap Netweaver Developer Studio

JVM terminated.Exit Code=1

C:\jdk1.3.1_09\bin\javaw.exe

-Xmx512m

-Xms128m

-XX:PermSize=32m

-XX:MaxPermSize=128m

-XX:NewSize=32m

-XX:MaxNewSize=128m

-XX:NewRatio=2

-cp C:\ProgramFiles\SAP\JDT\eclipse\SapStartup.jar com.sap.ide.eclipse.startup.Main

-os win32

-ws win32

-arch x86

-feature com.sap.java.ide

-showsplash C:\ProgramFiles\SAP\JDT\eclipse\SapIde.exe

-showsplash 600

Any help on this is greatly appreciated

Thanks

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

I have the same bloody error and it is annoying me quite a bit. I was really looking forward to playing with this thing over the weekend but if it can't even start right after successful install + reboot ....

Please help us out, cos I won't have another time soon to take a look.

This is what I find in the eclipse logs everytime it attempts to boot. I have no other IBM eclipse environment on this machine.

thanks,

Frank Feldmann

-


Eclipse Log -


An unexpected exception has been detected in native code outside the VM.

Unexpected Signal : EXCEPTION_ACCESS_VIOLATION occurred at PC=0x77d8c059

Function name=(N/A)

Library=C:WINDOWSsystem32USER32.dll

NOTE: We are unable to locate the function name symbol for the error

u00A0u00A0u00A0u00A0u00A0u00A0just occurred. Please refer to release documentation for possible

u00A0u00A0u00A0u00A0u00A0u00A0reason and solutions.

Current Java thread:

at org.eclipse.swt.internal.win32.OS.DrawTextW(Native Method)

at org.eclipse.swt.internal.win32.OS.DrawText(OS.java:1244)

at org.eclipse.swt.graphics.GC.drawText(GC.java:1265)

at org.eclipse.swt.graphics.GC.drawText(GC.java:1216)

at org.eclipse.swt.custom.CLabel.onPaint(CLabel.java:380)

at org.eclipse.swt.custom.CLabel.access$0(CLabel.java:287)

at org.eclipse.swt.custom.CLabel$1.paintControl(CLabel.java:102)

at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:80)

at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:77)

at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:843)

at org.eclipse.swt.widgets.Composite.WM_PAINT(Composite.java:665)

at org.eclipse.swt.widgets.Control.windowProc(Control.java:2726)

at org.eclipse.swt.widgets.Display.windowProc(Display.java:1992)

at org.eclipse.swt.internal.win32.OS.UpdateWindow(Native Method)

at org.eclipse.swt.widgets.Decorations.setVisible(Decorations.java:1247)

at org.eclipse.swt.widgets.Shell.setVisible(Shell.java:1012)

at org.eclipse.swt.widgets.Shell.open(Shell.java:676)

at org.eclipse.jface.window.Window.open(Window.java:538)

at org.eclipse.ui.internal.WorkbenchWindow.open(WorkbenchWindow.java:357)

at org.eclipse.ui.internal.Workbench.openFirstTimeWindow(Workbench.java:750)

at org.eclipse.ui.internal.Workbench.init(Workbench.java:581)

at org.eclipse.ui.internal.Workbench.run(Workbench.java:1319)

at com.tssap.util.startup.WBLauncher.run(WBLauncher.java:79)

at org.eclipse.core.internal.boot.InternalBootLoader.run(InternalBootLoader.java:831)

at org.eclipse.core.boot.BootLoader.run(BootLoader.java:462)

at java.lang.reflect.Method.invoke(Native Method)

at com.sap.ide.eclipse.startup.Main.basicRun(Main.java:257)

at com.sap.ide.eclipse.startup.Main.run(Main.java:751)

at com.sap.ide.eclipse.startup.Main.main(Main.java:566)

Dynamic libraries:

0x00400000 - 0x00405000u00A0u00A0D:DevToolsJavaJ2EE-1.3.1injavaw.exe

0x77F50000 - 0x77FF7000u00A0u00A0C:WINDOWSSystem32 tdll.dll

0x77E60000 - 0x77F46000u00A0u00A0C:WINDOWSsystem32kernel32.dll

0x77DD0000 - 0x77E5D000u00A0u00A0C:WINDOWSsystem32ADVAPI32.dll

0x78000000 - 0x78086000u00A0u00A0C:WINDOWSsystem32RPCRT4.dll

0x77D40000 - 0x77DC6000u00A0u00A0C:WINDOWSsystem32USER32.dll

0x77C70000 - 0x77CB0000u00A0u00A0C:WINDOWSsystem32GDI32.dll

0x77C10000 - 0x77C63000u00A0u00A0C:WINDOWSsystem32MSVCRT.dll

0x6D420000 - 0x6D4F9000u00A0u00A0D:DevToolsJavaJ2EE-1.3.1jreinhotspotjvm.dll

0x76B40000 - 0x76B6C000u00A0u00A0C:WINDOWSSystem32WINMM.dll

0x6D220000 - 0x6D227000u00A0u00A0D:DevToolsJavaJ2EE-1.3.1jreinhpi.dll

0x6D3B0000 - 0x6D3BD000u00A0u00A0D:DevToolsJavaJ2EE-1.3.1jreinverify.dll

0x6D250000 - 0x6D268000u00A0u00A0D:DevToolsJavaJ2EE-1.3.1jreinjava.dll

0x6D3C0000 - 0x6D3CD000u00A0u00A0D:DevToolsJavaJ2EE-1.3.1jreinzip.dll

0x6D340000 - 0x6D348000u00A0u00A0D:DevToolsJavaJ2EE-1.3.1jrein et.dll

0x71AD0000 - 0x71AD8000u00A0u00A0C:WINDOWSSystem32WSOCK32.dll

0x71AB0000 - 0x71AC4000u00A0u00A0C:WINDOWSSystem32WS2_32.dll

0x71AA0000 - 0x71AA8000u00A0u00A0C:WINDOWSSystem32WS2HELP.dll

0x71A50000 - 0x71A8B000u00A0u00A0C:WINDOWSSystem32mswsock.dll

0x76F20000 - 0x76F45000u00A0u00A0C:WINDOWSSystem32DNSAPI.dll

0x76FB0000 - 0x76FB7000u00A0u00A0C:WINDOWSSystem32winrnr.dll

0x76F60000 - 0x76F8C000u00A0u00A0C:WINDOWSsystem32WLDAP32.dll

0x76FC0000 - 0x76FC5000u00A0u00A0C:WINDOWSSystem32 asadhlp.dll

0x2B3E0000 - 0x2B425000u00A0u00A0D:DevToolsSAPStudioeclipsepluginsorg.eclipse.swt.win32_2.0.2oswin32x86swt-win32-2052.dll

0x771B0000 - 0x772D1000u00A0u00A0C:WINDOWSsystem32ole32.dll

0x77340000 - 0x773CB000u00A0u00A0C:WINDOWSsystem32COMCTL32.dll

0x763B0000 - 0x763F5000u00A0u00A0C:WINDOWSsystem32comdlg32.dll

0x63180000 - 0x631E5000u00A0u00A0C:WINDOWSsystem32SHLWAPI.dll

0x773D0000 - 0x77BC2000u00A0u00A0C:WINDOWSsystem32SHELL32.dll

0x77120000 - 0x771AB000u00A0u00A0C:WINDOWSsystem32OLEAUT32.dll

0x76390000 - 0x763AC000u00A0u00A0C:WINDOWSSystem32IMM32.dll

0x71950000 - 0x71A34000u00A0u00A0C:WINDOWSWinSxSx86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.10.0_x-ww_f7fb5805comctl32.dll

0x5AD70000 - 0x5ADA4000u00A0u00A0C:WINDOWSSystem32uxtheme.dll

0x63000000 - 0x63014000u00A0u00A0C:WINDOWSSystem32SynTPFcs.dll

0x77C00000 - 0x77C07000u00A0u00A0C:WINDOWSsystem32VERSION.dll

0x2B9C0000 - 0x2B9CD000u00A0u00A0C:Program FilesYzDockYzDock.dll

0x74C80000 - 0x74CAC000u00A0u00A0C:WINDOWSSystem32oleacc.dll

0x55900000 - 0x55961000u00A0u00A0C:WINDOWSSystem32MSVCP60.dll

0x76C90000 - 0x76CB2000u00A0u00A0C:WINDOWSsystem32imagehlp.dll

0x6D510000 - 0x6D58D000u00A0u00A0C:WINDOWSsystem32DBGHELP.dll

0x76BF0000 - 0x76BFB000u00A0u00A0C:WINDOWSSystem32PSAPI.DLL

Local Time = Sat Sep 27 19:07:19 2003

Elapsed Time = 5

#

  1. The exception above was detected in native code outside the VM

#

  1. Java VM: Java HotSpot(TM) Client VM (1.3.1_09-b03 mixed mode)

#

Former Member
0 Kudos

How much memory do you have on that PC? I have seen this on a PC which did not have the requested minimum (512meg). We closed the SAP C11 system and then tried opening Netweaver on its own and it worked.

Former Member
0 Kudos

You seem to use jdk1.3.1_09 which causes the trouble. Please uninstall the Sneak Preview edition and the jdk1.3.1_09, install jdk1.3.1_07 (if you have the Sneak Preview CD the jdk1.3.1_07 is included) and install the Sneak Preview edition once more. Now it should work.

Greetings

Ivo

Former Member
0 Kudos

The install instructions state that a JVM < 1.4.x is required - not totally true. I have found that a JVM <= 1.3.1_08 is required, due to an incompatibility between the version of Eclipse included with the sneak preview and the later JVM's.

The same thing happened to me, and the reinstall worked perfectly. Be aware, however, that I had to uninstall the JVM/JDK, uninstall the sneak preview, and then reinstall the JVM/JDK and then reinstall the sneak preview before I got it all to work OK. (Took a long time on my 256mb laptop, too, but I'm here to tell you that it does work.)

sarat_addanki2
Explorer
0 Kudos

Hi

The problem was due to jdk1.3.1_09. Used jdk1.3.1_07 and it working fine now..

BIG THANKS!!!!!

Former Member
0 Kudos

Hi,

I had the same issue..

For me it worked to install jdk1.3.1_07 in addition to jdk1.31_09 and after that to deinstall the _09 version. Then I simply renamed the the _07 folder in _09.... works!

Hope this helps..

Clemens