cancel
Showing results for 
Search instead for 
Did you mean: 

net value changes......,

Former Member
0 Kudos

Hi gurus,

I have a problem in Netvalue KF..., when i am trying to upload data from flat file which resides in application server.., i have 3 KF related to price..., i have the data like the following...,

1stKF 2nd KF 3rd KF

-


-


-


837,23 9834,75 8376,098

8373.234 8765,32 73653,789

so here because of ' , ' my loading is terminated . but in PSA some records are showing error because of this.

i tried to rectify it manually in PSA, but there is lot of records there... so i am planning to write a routine

in transfer rules for all these 3 keyfigures for getting valid value like 837,23 to 83723.

so how would i achieve this...? anyone can help me out & send coding for eliminating , and returning remaining values same...,

waiting for ur inputs plz.........

Regards

Swetha

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Swetha,

As Roberto said make "," as your decimal separator and "." as your thousand separator. I guess ""(space) would be your Data separator.

Try this and let us know.

Bye

Dinesh

Former Member
0 Kudos

Dear dinesh,

thankx a lot for ur reply...

expecting more frm kind of help from your end...

once again, thankx & take care....

i update you tomorrow...

Warm Regards

Swetha

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi,

If you have FTP access then you can donwload it your PC, Change the format and then upload it back.

Otherwise you would have to do it as AHP suggested or write an ABAP routine.

Bye

Dinesh

Former Member
0 Kudos

Hi Dinesh

thankx for reply. if i follow AHP suggested information, so which things i have to manage in infopackage level...,

or if i want to write ABAP routine, so where do i write it .... is it in transfer rules or somewhere else...

plz. advice me....

Respond AHP also....

Regards

Swetha

Former Member
0 Kudos

Hi dear,

check if in your infopackage you have as decimal separator ','.

Hope it helps!

Bye,

Roberto

0 Kudos

hi Swetha,

i think no need to write routine,

what's you flat file type/format ? csv ? what's the Data Separator -> comma ?

check settings in your infopackage >> tab 'external data'

- file type, data separator

- Separator for Thousand

- Character Used for Decimal

try to click 'preview' to check data validity.

Former Member
0 Kudos

Dear dinesh & A.H.P,

thankx for ur suggestions.

yes i'm using .csv file..., so no need of writting code you mean...

But dear dinesh my file is in application server.., so i am don't have permissions to change it....

can you tell me is there any another way of maintaining it....

i will check & update you...,

Regards

Swetha

Message was edited by: swetha saxena

Former Member
0 Kudos

Hi Swetha,

I guess you are using ".csv" format. You can change the format of the column for the key figures in the flatfile itself. This way you need not invest any time for writing any code.

Just select the KF column in "Excel" -> right click -> format cells -> and choose the correct format.

Bye

Dinesh