cancel
Showing results for 
Search instead for 
Did you mean: 

need to connect SQL Server 2008 and CR 2008 via OLE DB SQL Server Provider

Former Member
0 Kudos

I am relatively new to Crystal but have done some minor design/layout work in the past. I just purchased CR 2008 and dowloaded a Eval Copy of SQL Server 2008 to build test reports that will then be uploaded to a hosted web app we use for use with live data.

I am having some trouble, however, getting SQL server and CR 08 to talk the way I need them to. We have to use the OLE DB for SQL Server Provider connection for the reports to work in our hosted live environment but I cannot get this to work on SQL 2008. The server never appears in the Server dropdown and if I manually type it get the following error:

 failed to open connection.
Detail ADO Error Code: 0x80004005
Source: Microsoft OLE DB Provider for SQL Server
Description: [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access is denied.
SQL State: 08001
Native Error: 17 [Database Vendor Code: 17 ]

I am setting up the connection through the Database Expert choosing the OLE DB (ADO) folder and then selecting 'Microsoft OLE DB Provider for SQL Server' then entering my server name, user id, password, and Database name.

I have uninstalled and reinstalled everything twice. I have installed the Microsoft SQL Server 2008 Analysis Service 10.0 OLEDB Provider pack.

My provider/host does use SQL Server 2005 but since I can't get a free Evaluation version of it I have to use 2008 for my local copy. I have searched the web over (including here) and cannot find an answer to my issue.

I cannot use SQL Server Express version because our copy of the DB is too big. I cannot use the Native 10 provider as the reports will not work once I have uploaded them to the live data.

any help anyone can provide for this would be GREATLY appreciated. Thank you and sorry if this is a dupe post. I have searched everywhere and cannot find the answer.

Accepted Solutions (0)

Answers (1)

Answers (1)

0 Kudos

Hello,

Go to Microsoft's site and download their OLE DB test tool and test the connection. Did you install the MS client tools to test the connection also?

As a test try creating an ODBC System DSN just to verify you can connect and create a report also.

And don't use the SA account, MS 2008 disabled it, sort of, so you'll have to create a new account and grant permissions to any table you need to use.

SQL 2008 changed security model big time so it's not the same as 2005 once was....

Good luck

Don

Former Member
0 Kudos

I don't use the SA login because my host company requires we use the SQL Server Auth not Windows. I have tried the ODBC and it works fine so now I just need a little more detail on this OLE DB test tool. I found it as part of the MDAC SDK on MSDN but have no clue how to use it and their help assumes a much higher SDK knowledge then I have. Can someone give me a quick walk through?

Former Member
0 Kudos

I tinkered around with the OLE DB test tool and figured out enough to know what I was doing wrong. Thanks for the help.

Former Member
0 Kudos

... would it have been too hard to spell out what you did to solve the problem, if someone would have answer your question the way you did, maybe you would have known how the rest of the world feels everytime they stumble in a post with a solution that is ... in your brain.... WAL