cancel
Showing results for 
Search instead for 
Did you mean: 

Navigation Error in NetWeaver Mobile 7.1

Former Member
0 Kudos
27

Hi all,

I´ve a question regarding NetWeaver Mobile 7.1 Navigation.

I have an application with 2 views. Now I want to navigate from the start-view to the second-view.

The steps which I´ve done are the same as in a normal webdynpro application:

create an outbound plug for the first view.

create an inbound plug for the second view.

connect the outbound plug with the inbound plug via link.

create a button.

create an action which fires the outbound plug.

set the action for the button.

When I test the navigation a get the following error:

I hope somebody can help me with this issue.

Thanks and regards,

Michael

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

The steps you have done are correct. But anyway try this approach

create an outbound plug for the first view.

create an inbound plug for the second view.

connect the outbound plug with the inbound plug via link.

create a button but by using "apply template" approach. Just right click and say apply template and choose "Action Button" and give some name and chose "NEXT" and then choose "Fire Plug" option and just choose the outbound plug.

Then rebuild and test the application.

Hope it works because i tested and it worked fine.

Best Regards,

Siva.

PS:Reward with some points if you find the post useful.

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Siva,

I tested the navigation as you described.

Unfortunately I get the same error message as before.

Just for information:

I use the NetWeaver Developer Studio 7.1 SP3 Trial with Trial NetWeaver Mobile Plugins.

I thought this could be a reason, but my colleague use the same and the navigation works.

Are there special .jar files or something else which is needed for the navigation ?

I would be appreciate for every helpful answer.

Thanks and regards,

Michael