cancel
Showing results for 
Search instead for 
Did you mean: 

Navigate to a Page

Former Member
0 Kudos

Hi,

How do i navigate to a page when i click a Link.

Ex: Home Page has 2 links.

Link1.

Link2.

Link1 and Link2 actually are two pages assigned to my role..i can click the pages on the TLN to go to these pages.

How can i go to Link1 page when i click Link1 on the Homepage..

the effect shud be "Clicking the link1 on Home Tab shud be as good as clicking the Link1 page on the TLN"

Any ideas, how cud i produce this affect?

Thanks

View Entire Topic
Former Member
0 Kudos

Hi Peter

You can create a component and use the donavigate methods for this.

<b>Navigation to other Tabs</b>

Open the role that has the iview to be navigated.Select the iview to which you want to navigate <b>from the role</b>(do not directly open the iview,open it from role).Then click on the properties.The property editor of the iview appears on the right of the screen.Select the Information property from the dropdown.Then copy the pcdlocation property and give it as below in the component you are developing.

WDPortalNavigation.navigateAbsolute("ROLES://give it here:the pcdlocation property", WDPortalNavigationMode.SHOW_INPLACE, WDPortalNavigationHistoryMode.NO_DUPLICATIONS, (String)null);

WDPortalNavigation.navigateAbsolute method is for webdynpro.

If you are using portal component you can use the EPCM.doNavigate() method

<a href="link" onclick="return EPCM.doNavigate('ROLES://portal_content/MyFolder/myrole/Test/myiview');"> click to navigate to myiview</a>

Regards

Geogi

Former Member
0 Kudos

Guess i need to word my issue in a different way:

EG:

Role_A has PAGE_1, and ROLE_B has PAGE_2.

PAGE_1 has LINK_2 that opens PAGE_2.(LINK_2 is an htmlb link and can open a link using EPCM.doNavigate())

If i click LINK_2 then it opens PAGE_2 there itself but won't actually naviagate to PAGE_2...The effect is, on ROLE_A PAGE_2 wud be shown....with PAGE_2 title not highlighted...

if u have some time, plz check it out...

Appreciate ur Time Geogi,

Regards,

Former Member
0 Kudos

Hi Peter

In the Sys admin@sys config@service config@applications@com.sap.portal.epcfloader@Services@epcfloader,check whether the framework level is 2 and whorprotectmodedefault to 2.Save the details and restart the service by right clicking the com.sap.portal.epcfloader. Check whether the Epcf is working properly.

Regards

Geogi

Former Member
0 Kudos

Hi Peter,

try out the follwing forum post. That query is almost same as urs.

Regards

gEorgE