cancel
Showing results for 
Search instead for 
Did you mean: 

more XI 3.0-->IDoc-->R/3 - Trouble

Former Member
0 Kudos
160

hi,

i was trying to set up a scenario in which an idoc matmas04 is sent via XI to the receiver-R/3 instead of pure ALE/IDoc transfer.

I get the corresponding Error in the XI-Monitoring:

translated to English it says something like: Receiver Service can't be acknowledged as ALE Logical System.

As Outbound and Inbound Interfaces I use the imported MATMAS04-Idoc - I followed all the required steps in the configuration. I use Services without partner where both R/3s appear as corresponding business-services (which I set up in the SLD). Both services are labelled "receiver". The sender uses communication channel: idoc, which seems to be alright, and the receiver uses GeneratedReceiverChannel_IDoc.

on the XI in transaction idx2 the idoc-type shows up, in idx1 i declared a port for the receiving system, which is pointless i guess...

in SXMB_ADM I set the entry in configuration integration server, configuration data-idoc to XML_CONVERSION value 2...

any further ideas welcome - thanx in advance,

matthias

Accepted Solutions (1)

Accepted Solutions (1)

cdumont69
Contributor
0 Kudos

Hello,

You can find help on this weblog :

/people/saravanakumar.kuppusamy2/blog/2005/01/20/configuration-tips-for-a-business-serviceintegration-process-to-send-back-ale-audit-idoc

"...To specify the logical system, open Integration directory and select the Business Service that is configured as receiver for the IDOC.Switch to Edit Mode and choose the "Service" menu and then the menu option "Adapter-specific identifiers"..."

Regards,

Chris

Former Member
0 Kudos

Hi,

actually a very helpful weblog - I also had to check different settings in the systems involved as I wasn't sure eg in the XI directory what to enter in the fields for receiver-channel idoc (it's sometimes hard to figure out which perspective is being used (XI or Receiver system).

Thanks a lot - once more,

Matthias

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Matthias,

I have a similar error situation like yours. Here is the snapshot of the Error ID: ATTRIBUTE_INV_RCV_SERV

Details:

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <!-- Call Adapter

-->

- <SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="">

<SAP:Category>XIAdapter</SAP:Category>

<SAP:Code area="IDOC_ADAPTER">ATTRIBUTE_INV_RCV_SERV</SAP:Code>

<SAP:P1 />

<SAP:P2 />

<SAP:P3 />

<SAP:P4 />

<SAP:AdditionalText />

<SAP:ApplicationFaultMessage namespace="" />

<SAP:Stack>Receiver service cannot be converted into an ALE logical system</SAP:Stack>

<SAP:Retry>M</SAP:Retry>

</SAP:Error>

Any clues to fix it are appreciated.

Thanks,

Raghu