cancel
Showing results for 
Search instead for 
Did you mean: 

Modifying crosstab add extra rows with numerical value

0 Kudos
36

I am modifiying an existing crosstab that originally  displayed dates as row names and test names as columns. I changed the rows to be the test names and the columns to be the dates.  I used the crosstab expert to change these which seemed pretty simple.  It worked exept it has added and additional number of  rows for however many test names there are.  Why did it do that and how do I fix?  Here is an example.  This particular example has 4 test names so it through in 4 extra rows with a 1, 2, 3 and 4.

                         11/28/12     12/3/12

Test Name 1          6.0               6.1

Test Name 2          4.4               4.4

1

2

3

4

Test Name 3          9                    9

Test Name 4          .012               .012

Accepted Solutions (0)

Answers (1)

Answers (1)

abhilash_kumar
Active Contributor
0 Kudos

Hi Jill,

That is strange! What happens when you create a 'New' crosstab with just the Test Names as Rows? Does it show the numerical rows?

Also, does the database have these values?

-Abhilash

0 Kudos

The same happened when I created a new crosstab.  I do not see the 1, 2, 3, 4 test names in the database.

0 Kudos

The other pondering issue is I have it set to suppress blanks.  Since these rows are blank why are they still showing? 

0 Kudos

I thought some screen shots may help.  The first one is pretty much what I typed above but it is the actually report. (crosstab) I went back into the cross tab and added the rowsequence value to see if it would bring back any values that would give me a lead on what is going on.  That is the second attachement (crosstab_rowsequence).  This one shows a value of 100 for each one of these mysterious rows.

Former Member
0 Kudos

Does your data contain Null values?

Any way we can see the raw data from the sql that crystal runs?

abhilash_kumar
Active Contributor
0 Kudos

Well, even if it contains Nulls, it is would only display zeroes (with a few options checked under File > Options).

-Abhilash

0 Kudos

Hey All, Thanks for all the responses.  I was able to figure out how to prevent them from showing (still not quite sure why they were there).  There was a field in the database being pulled called rowsequence.  I added that to my crosstab and revealed that all of these numeric named rows were set to rowsequence 100.00.  I added a selection formula for record where rowsequence <> 100.00 and they no longer are in the crosstab.  I have another question related to sort order but I will open a new post. Thanks Jill