Showing results for 
Search instead for 
Did you mean: 

minisap ABAP installation on 1GB XP machine

Former Member
0 Kudos

Installation itself worked pretty uneventful. However, before I run out and buy more RAM to bring my laptop

up to the recommended level (1GB to 2GB) I need to do a sanity check with the forum participants:

The MMC starts the processes similarly to J2EE which works fine, but in ABAP system Dispatcher (disp+work.exe) gets shut down a short while after starting. After refresh it won't even restart.

I have also noticed that DB is not available through MMC but I can connect to it from the Database Manager, not sure why...

Had to create two nsp users (nspadm and SAPServicensp) in the database manually and was expecting those to be created automatically during installation.

My MMC system log is showing th following hard errors:

SAP Basis System: Initialization DB-Connect Failed, Return Code 000256

Database: Database error -709 at CON

My trace file logged this:

T:3208 ======> Connect to SAP gateway failed

Connect_PM GWHOST=localhost, GWSERV=sapgw00, ASHOST=localhost, SYSNR=00

LOCATION CPIC (TCP/IP) on local host

ERROR partner not reached (host localhost, service 3300)

TIME Wed Aug 17 13:04:45 2005


COMPONENT NI (network interface)


RC -10

MODULE nixxi_r.cpp

LINE 8596

DETAIL NiPConnect2


ERRNO 10061



My developer trace file has this:

Wed Aug 17 13:50:10 2005

      • ERROR => W0 (pid 252) died [dpxxdisp.c 12187]

      • ERROR => W1 (pid 2312) died [dpxxdisp.c 12187]

my types changed after wp death/restart 0x89 --> 0x88

      • ERROR => W2 (pid 3412) died [dpxxdisp.c 12187]

my types changed after wp death/restart 0x88 --> 0x80

      • DP_FATAL_ERROR => DpWPCheck: no more work processes


increase tracelevel of WPs

killing W0-252 (SIGUSR2)

      • ERROR => DpWpKill(252, SIGUSR2) failed [dpxxtool.c 2468]

killing W1-2312 (SIGUSR2)

      • ERROR => DpWpKill(2312, SIGUSR2) failed [dpxxtool.c 2468]

killing W2-3412 (SIGUSR2)

      • ERROR => DpWpKill(3412, SIGUSR2) failed [dpxxtool.c 2468]

NiWait: sleep (10000 msecs) ...

NiISelect: timeout 10000 ms

NiISelect: maximum fd=1673

NiISelect: read-mask is NULL

NiISelect: write-mask is NULL

Wed Aug 17 13:50:20 2005

NiISelect: TIMEOUT occured (10000 ms)

dump system status

Workprocess Table (long)

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

disp+work process stops for me even after I've installed both the central and database instace several times. If i check the syslog, its seems like everything goes downhill after error:

SAP Basis System: Initialization DB-Connect Failed, Return Code 008192

Anyone know what this means?

Active Contributor
0 Kudos

I remember having troubles with DB startup, issue was missing network connection (forgot to activate loopback adapter while disconnected from network).

Possible cause for your error?

Any more helpful error messages?

Developer Advocate
Developer Advocate
0 Kudos

Looks like the database was not install correctly, try re-installing the database instance.


Rich Heilman

Former Member
0 Kudos

Hmm, have been trying that but during reinstall I keep getting the following:

ERROR 2005-08-17 17:59:28

FSL-02015 Node files.../SAPNetWeaver04SneakPreviewABAP/Installation_Master/IM01_NT_I386/../../NSPExport/DATA does not exist.

Tried uninstalling one instance and all the instances, tried sap and Windows uninstalling, but there must be something in the registry that prevents me from a clean reinstall...

Active Contributor
0 Kudos

Did you see Rich's weblog at [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] [original link is broken] if you had extracted your .rar into the desktop (this caused file path to be very long) you may get this error.



Message was edited by: Durairaj Athavan Raja

Former Member
0 Kudos

Don't forget to uninstall database instance using dbmcli prior to reinstall it again. I got error regarding unknown database user during reinstall without uninstallation.