Showing results for 
Search instead for 
Did you mean: 

MIME Object Transport

Former Member
0 Kudos


I have a BSP  that includes Javacript file as MIME object. Application was created as a local object, since the proof of concept worked fine, now we decided to move that to QA environment. Created Transport request for all the Objects(including model, views, controllers classes) ans transported to QA. When we opened the application in SE80 we got a message "The Application Directory does not exist in the MIME repository", we realized that MIME object was not included in original transport, so we have created another transport for MIME object using OBJECT DIRECTORY ENTRY and transported to QA. Still I am getting the same error. We have transported many BSP applications earlier we had no such problem.

Is anybody know how to solve this problem.



Accepted Solutions (0)

Answers (1)

Answers (1)

Active Contributor

Hallo Suresh,

Here comes the man again with his "problems should go into OSS" mantra. Unfortunately this is true, for the simple fact that if there is a problem, at least two other groups (besides ourselves) can be involved. And OSS is the only trouble ticket system to route problems around.

But, before we go this way, let me check just one aspect of handling. When you create a BSP application, three different types of development objects are created (BSP=WAPA, Mime Repos stuff = SMIM and ICF node = SICF). You should of course keep in mind to transport all of them.

Now, when you are in SE80, looking at the BSP application, you will see the "folder" called MIMES, and when you expand it, you see your mime objects. However, in this navigation tree, the mimes folder is just a dummy object. The mime objects are actually real.

To transport the correct matching folder for your BSP application, you have to go actually into the MIME repository browser. Start SE80. At the left where the tree is,  you will see a horizontal bar with the words "MIME Repository". Press this. Navigate to where you BSP application node is. This is now directly the real folder object as it is in the MIME repository. Right mouse on folder, select "Further actions --> Assign to new package". There will be a popup for the new package (as you don't want $TMP anymore), plus another popup for transport.

Do the same for all MIME objects inside this folder.

In SE09, you will now see a number of "R3TR SMIM" objects in the transport.

If this does not work, please open an OSS message with the exact steps tp follow so that we can look at this.

thanks, brian

Former Member
0 Kudos

Hi Brian,

I usually approach GURUs to get the answers in a easy way. I did the transport the same way you mentioned it workd fine. I knew that I can get a definite solution/answer from you(quick turnaround). I have posted some java iView based messages in Enterprise Portals three weeks ago, no response yet. If SDN has guys like you everyone will get answer as well as good understanding about the system too.

Keep up your good always.