cancel
Showing results for 
Search instead for 
Did you mean: 

mime-download problem

Former Member
0 Kudos
132

Hi.

I use a custom report to output information into two different mode: standard output report (with ALV) and standard output into microsoft excel using mime-download macro.

My report generate the information and after this, for the excel output, I use dynpro 100 where I call mime-download in PBO step. The problem is that if I execute my report with standard ITS service 'webgui' on a server ITS AGate version 6200.1014.44453.0 the system don't execute microsoft excel to output the data. If I execute the same report on a old ITS installation (4640.4000.36.7055) the system work correctly.

If I execute other custom module pool that work with mime-download the system work correctly. I suppose that the problem occurs only with report executed with webgui service.

Previously I had the same problem with pdf document and I solved the problem with the installation of ITS patch level 14.

Can you help me to solve this other problem?

Excuse for grammal errors.

Thanks,

Gianluca

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Simeone,

can't you insert a second download option for WebGUI only or use the ALV download functionality when not running it via a template?

former_member185704
Contributor
0 Kudos

Hi Gianluca,

Is your problem solved? If so, please grant reward points and mark this topic as answered.

Best regards,

Henning.

former_member228142
Active Contributor
0 Kudos

Hi Simeone,

the mime-download macro is intended for use in a IAC environment. If you want to download and execute a excel file in webgui I recommend to use the class CL_GUI_FRONTEND_SERVICES. This class provides the methods GUI_DOWNLOAD and EXECUTE which can be used. BTW, if you use these methods your report works also in SAPGUI for Windows and SAPGUI for Java.

Best regards,

Klaus