cancel
Showing results for 
Search instead for 
Did you mean: 

Migration AIX to Linux 46C

Former Member
0 Kudos
111

Hi Guys,

I have successfully migrated a whole bunch of ECC5 systems from AIX,SUN etc to Linux.

However, trying to do the same for a 46C system on AIX is not going so smooth.

Actually, this time my coleague did the migration and he used the migration monotor to export the 46C database on AIX and then imprted it into Linux x_86 64 bit system. The Kernel CD for this is only availabe to customers with extended maitenance.

Even though according to him the migration finished successfully, I have a problem when trying to get into the system. The system started with no problems and R3trans -d works fine. But when I tried to login I get a message "Pragram SAPMS380 d" at the bottom and if i click on it something in German which seems to mean function not possible.

Also, for some reason I am not able to display the temp license:

saplicense -show

      • SAPLICENSE (Release 46D) ERROR ***

ERROR: Can not read number of license entries

DETAILS: DbSlRead failed with return code 107

ORA-00942: table or view does not exist

There are similar errors in the developrt traces like:

***LOG BZA=> table TBTCO doesn't exist on database [dbtran 6991 ]

M *** ERROR => BtcMrkZombies: db_rsql-call failed, rc: 32 [btcclean.c 514]

Error Code GEN_PROGRAM_NOT_EXISTS.

I want to know if SAP really supports this kind of migration because it seems to me that this is not supported, hnce these kind of errors and no notes on them.

Has anyone does this kind of migration with this release?

Any ideas?

Thanks

Cyrus

Edited by: cyrus brocha on Dec 20, 2007 10:57 PM

Accepted Solutions (0)

Answers (5)

Answers (5)

Former Member
0 Kudos

Thanks Ralph.

I had noticed in the trace files that several tables were missing and you were right.

When I executed the Oracle command, there are 5000 tables less in the new database.

So, I will just do the export/import again and see if all tables do get exported.

Regards

Cyrus

Former Member
0 Kudos

Hi Cyrus,

it seems that your colleague has not imported all tables. The temporary license normally gets imported by the R3setup or by SAPinst (in current releases). If you use only R3load or Migmon for the migration, your system will get no temporary license.

But in your ticket you copied also the error message: "table TBTCO doesn't exist on database". Your system probably miss not only this table. Check if you got all tables in the new system before you try to bring it up the next time. May be you could start by simply counting tables in both databases (using sqlplus):

SELECT owner, count(*) FROM dba_tables WHERE owner LIKE 'SAP%' GROUP BY owner;

Best regards

Ralph

Former Member
0 Kudos

I tried with the permanent license and doesnt work. Looks it its not a license problem.

Former Member
0 Kudos

Hi Sachin,

Yes, I was ofcourse going to apply for permanent license. But, I find it strange that a temporary valid license did not get installed during the installation. I am sure it did get installed, its just that it cannot be read and confirmed.

I will try installaing permanent license and try.

Regards

Cyrus

Former Member
0 Kudos

Hi,

I think after the migration you have to apply the new license as the OS/DB are changed, even please upgrade the kernel and use the 620 release as we can use the 620 release kerenel with 4.6C system

Hope this will help you, let me know if you need any more help.

Best Regards,

Sachin.