cancel
Showing results for 
Search instead for 
Did you mean: 

Message "'UI Update' has encountered a problem." appears often while debugging in ADT

NemanjaSimovic
Participant
119

Hi ADT developers and Community,

Lately, I got very often the message "'UI Update' has encountered a problem." every time when I want to open a table in debugger. Like on a image below:

NemanjaSimovic_1-1718783832496.png

I'm using:

Eclipse IDE for Java Developers (includes Incubating components)
Version: 2024-06 (4.32.0)
Build id: 20240606-1231

with Darkest Dark Theme with DevStyle 2024.2.0.

Is this a bug or maybe there are something to do in Preferences? Appreciate any hint. 😉

Thanks.

Regards,
Nemanja

ysoethoff
Product and Topic Expert
Product and Topic Expert
We strongly recommend to not use DevStyle / Darkest Dark Theme together with ADT, as the way how it works is very invasive and we cannot guarantee the functionality in combination with ADT. Can you please try to reproduce the issue using an installation without DevStyle?
NemanjaSimovic
Participant
0 Kudos
I'm using DevStyle / Darkest Dark theme with ADT for over two years. But yes, I have noticed some issues, but nothing major. But if recomendation is not to use it, then I guess it's best not to use it. It had really good icons. 😞 I'll try with default theme and give a feedback. 👍
NemanjaSimovic
Participant
0 Kudos

Hi @ysoethoff,

I removed Darkest Dark theme from Eclipse, and used original Dark theme. Changed couple of colors that annoyed me, though. But occasionally I still get similar message "Argument not valid" :

NemanjaSimovic_1-1720597414764.png

Now I don't believe that Dark Theme that came with the Eclipse could be the cause. At some point I'll try with completely default theme and options, and write here result. 😊

BR,
Nemanja

Accepted Solutions (0)

Answers (0)