cancel
Showing results for 
Search instead for 
Did you mean: 

Median doesn't work in webi charts

former_member611722
Participant
0 Kudos

Hi everyone,

I've created a chart to show the median number of days it takes for an analyst to build a product for a particular time frame/ the analyst should be able to see the same metric for their team (seeing median number of days it takes for THE TEAM to build a product for a particular time frame). Now what happens is that when I select a number of analysts from an input control that lists the name of the analysts, the median is not calculated correctly!

here is the screenshot of the chart:



as you can see, the vell above the chart should show the value of 3, however, it is showing 4.

I've used a couple of formulas here:

The formula for the horizontal green bar:

=If [Median_Bld]>[Median_builder_all] Then [Median_Bld]

- Median([Build Complete Days]= [Median_Bld] and where [Build Complete Days]= is the median number of days it take to build a product

- [Median_builder_all] =Median([Build Complete Days])ForAll([Builder Full Name])

The formula for the orange bar:

=If [Median_Bld]>[Median_builder_all] Then [Median_Bld]

These variables have been explained above

The formula for the green vertical line:

=Median([Build Complete Days])ForAll([Builder Full Name])

- [Builder Full Name] lists the name of each analyst

- [Build Complete Days]= is the median number of days it take to build a product

If all select the name of all analysts it works fine, however, when I only select a limited number of analysts, it doesn't work.

Your help and time is appreciated.

Accepted Solutions (0)

Answers (0)