cancel
Showing results for 
Search instead for 
Did you mean: 

MDG_S workflow

Former Member
0 Kudos
544


Hi

As even after matainance of IMG. acivity (Assign Processor to Change Request Step Number (Simple Workflow)), change request is saved but it is not triggering any workflow . All workflow pre -requsites are already dome. Workflow is working for MDG-F on same instance.

Is below customization is mandetory for MDG_S?

Assign Processor to Change Request Step Number in BRFplus for Supplier

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Sanjay/Pavan, I'am facing the same issue...can you please share how you guys fixed it? Thanks, Kp.

Former Member
0 Kudos

Hey Sanjay.. Im sure you'd have had this resolved by now... Would you mind me asking what you had to do get rid of this error. This is quite informative and everything I had done as well, except debugging the method

Thanks

Pavan

Former Member
0 Kudos

It depends on which workflow template you assigned to your MDG-S change request type. Can you post a screenshot of the MDG Change Request Type definition?

Former Member
0 Kudos

Hi

It is simple workflow template (WS54300005)

As wanted to trigger to workitem to only one user ID, not with parallel work items (No BRF+)

Also like to know differance between supplier UI ( Reletes Transaction BP from ECC) and Vendor Like UI ( Relates Transaction XK* from ECC).

If want to use vendor Like UI what are the disadvantages over supplier UI?

Former Member
0 Kudos

Did you activate the workflow linkage? Go to transaction SWETYPV and find the entries for BO BUS2250. There should be one without a receiver marked as active. If it is not active, you need to activate it.

The second thing is that this workflow uses the Supplier agent BRF+. Make sure you assign agents in the agent BRF+ table under the supplier node in MDGIMG (not the simple workflow).

Former Member
0 Kudos

Hi Abdullah

BUS2250 is already activated for CREATED action.I change workflow template to WS60800086 as it is for Rule based workflow from original workflow template .I maintained all users in decesion tables but seems stikl it is not working.

Also like to know differance between supplier UI ( Reletes Transaction BP from ECC) and Vendor Like UI ( Relates Transaction XK* from ECC).

If want to use vendor Like UI what are the disadvantages over supplier UI?

Former Member
0 Kudos

For the workflow problem (you might notice I tend to address one problem in each post):

The rule-based workflow should work. Did you get any errors in the workflow log? Run transaction SWI1 and post a screenshot of any errors you find.

Former Member
0 Kudos

Nothing in SWI1 as workflow is not triggerd after submission of chane request

Former Member
0 Kudos

Since you confirmed that the workflow linkage is activated, there seems to be a problem with triggering or capturing the event. Use SWEL and SWELS to trace events. SWELS is used to turn the WF trace on and off. SWEL is used to display the trace. Make sure to turn off the trace once you are done.

Former Member
0 Kudos

Hi Abdullah

Now I am able to activate change request through workflow and now getting error 'Process Errors After Activation' but it is with workflow template WS60800086 which is rule based workflow not with WS54300005 which is delivered by SAP along with data Model BP.

In the customizing activity 'Assign Processor to Change Request Step Number in BRFplus for Supplier'

I am getting below only for GET_AGENT path ( After importing data from client 000 also it shows nothing but saying import is successful)

So I am adding row as per below screen.

and event trace for WS54300005 is

Former Member
0 Kudos

I'm a little confused. Are you using the rule-based or WS54300005?

For WS54300005, the step number in your agent assignment configuration must correspond to the target step number. See the screenshots below. You entry should have 1 instead of 0 in the step column because you are going from the requester step (0) to the approver step (1). See these screenshots.

Former Member
0 Kudos

Hi Abdullah

When I try to use WS54300005 workflow template and assign processer to all (01,04,05,06 and07) the change requst step type it does not create any workitem in event trace (SWEL

Workflow is triggered If I uses wokglow template for rule based.But another issue for it . I am posting in seperate thread for this.

My question is why for WS5430005 it is no workitem is created?

Former Member
0 Kudos

Using the object type and key from you screenshot, try trouble shooting the problem using transaction SWUE. This transaction enables you to simulate & create events. If the transaction does not help, you can put a break-point in either the receiver function module or the receiver type function module. One of them must be throwing an error.

Former Member
0 Kudos

Hi Abdullah

Tried but no successful for transaction SWUE.

Soory I am fuctional guy and unable to put break point .

My question is that is I am following correct procedure functionally and assiging processors to change request step types for WS54300005 , The work item is not generated but when I replace WS54300005 with rule based WS then work item is created. Is some incorrect settings in assignment of proceeor done by me?

    

Former Member
0 Kudos

If one workflow starts then the other should start too. Most probably an exception is being generated in either of those function modules. You might need to use the help of an ABAP resource.

Former Member
0 Kudos

Hi  Abdullah

In SWEL we found event trce log as per below

But there is no Object Type as FLOWITEM in SWE2. Are you supposed to define it in SWE2 as New Entrity?

And also when try to create event in SWUE for object type FLOWITEM with event PROCESSED

and saying No (active) event receivers exist when selected the push button Event Receiver.

Not sure but Available Change Request Type dialog box ( Pop up box for selection of change request type similar to MDG-M) is not comeing in MDG 6.1

Former Member
0 Kudos

Actually, from the first screenshot above, you need to look into the first line in SWEL (the one with the green dot for object BUS2250). You can see that a workflow has started. Open that record and get the work item ID. Use the item ID in transaction SWI1 and see what is going on with the workflow instance.

Former Member
0 Kudos

Hi Abdullah

In SWI1 status is Error

In workflow log details it shows as

and workflow log with technical details it shoows errors as

Any clue?

Former Member
0 Kudos

Yes, the answer is in the last line in the error log. Check out what is wrong when calling rule 75700139 (using transaction PFAC). It calls function module USMD5_CREQUEST_ROLE_DET. This function generates an error when BAdI USMD_WF_AGENT is not implemented or when the BAdI generates an error.

Can you post a screenshot of the container of step 417?

Former Member
0 Kudos

Hi Abdullah

Below is screen shot for container

Also I opened seperate thread as unable to activate vender like UI instead of Supplier UI? Can you check that also please.

Former Member
0 Kudos

If you see the screenshot above, AGENT_FILTER is blank. It should contain MDGS_ERP.

Validate if enhancement spot MDG_BS_BP_WORKFLOW_SWITCH is implemented and activated in your system in enhancement implementation MDG_BS_SUPPL_WF_SWITCH_ERP.

Former Member
0 Kudos

Hi Abdullah

Is there any IMG activity linked with this? How to check this? Sorry for asking this but ......

Former Member
0 Kudos

Yes, here it is:

Former Member
0 Kudos

It is activated for me as welll in same  IMG node

But for enhacement spot below is screen shot and guess it is not activated

How to activate it as it asks access key when try to select edit button?

Former Member
0 Kudos

Are all your MDG-S business functions active?

To activate, double-click the BAdI name and then activate it from there. You should not need an access key (maybe a developer key though).

Former Member
0 Kudos

I meant you should double-click the BAdI implementation from your screenshot here: http://scn.sap.com/servlet/JiveServlet/downloadImage/2-15201712-494259/450-165/Enhacement+Spot.PNG

Former Member
0 Kudos

After double click on BADI name below screen appeared when one check box says implementation is active

Then why we need to activate it again?

Former Member
0 Kudos

The problem is that the AGENT_FILTER is blank. You need to ask someone to debug method CL_MDG_BS_BP_WF_POR=>GET_AGENT_FILTER to see why no value is returned.

Former Member
0 Kudos

Hi Abdullah

Need one help. Can you share Business Function name required for activation of enhacement implementation MDG_BS_SUPPL_WF_SWITCH_ERP?

Former Member
0 Kudos

It should be one of the three MDG-supplier business functions. You can find it by double-clicking the package name of the enhancement spot. There is a field in the package detail page that shows which switch a package is activated by.

Former Member
0 Kudos

i Abdullah

Seeing some strange issues for Application Coment and SoftwareComponent for same business function which is used for SWITCH

Can we say that some issue while activating MDG 6.1 ( Considering above issue , as per you SWITCH should be automatically activated during activation of business function only) ? As first we want to activate MDG 7.0 on EHP6 but due to some issue our technical team revoke setting required for activation of MDG 7.0 and then they go with activation of MDG 6.1.

Former Member
0 Kudos

I don't think there is a problem with your active business functions. Some of the earlier material & supplier functionality came with the MDG basic (financials). That's why the second screenshot contains MDG_FND.

Now that the business functions look OK, were you able to find out why the method I described earlier does not return anything?

Former Member
0 Kudos

Hi Abdullah

We have another box (SID-BMD) where MDG is already activated and it seems that above SWITCH is already active as SAP delivered (No Manual intervention)

Also found same issue for MDGF Data Model also.

For MDGF, SAP delivered Data replication structure as a out of box feature, but it is missing in my original system(SID-LEO) but do exits in another (SID-BMD)

Is there another way, to see Out of Box feature delived by SAP for MDG?

Former Member
0 Kudos

Does the Supplier workflow work in that system? If so, you might want to copy the same BRF+ configurations into the system that's not working to see what is wrong. Did you check why the method does not return a value as I described above?

Former Member
0 Kudos

Hi Adbullah

Workflow is working in another system but my question here is why SWITCH is not activated through Business Function in my original system (For same business function it is activated in another system).We found same type of issue in MDGF as well.So Can we say that activation of MDG is incomplete in my original system (As first we want to activate MDG 7.0 on EHP6 but due to some issue our technical team revoke setting required for activation of MDG 7.0 and then they go with activation of MDG 6.1)

Is there another way, to see Out of Box feature delived by SAP for MDG for all models are activated to confirm MDG activation is correct?

Is thie enhacement spot is called as Active, If yes why there is no column for status in implementation area (as per your screen snap on Jul 9, 2014 10:46 PM) Why CR not trigger the workflow

Former Member
0 Kudos

It looks like everything is activated fine in your system. I initially had a doubt that something was not active. When you showed me the screenshots, I asked you to debug the method and see why it is not returning back any value. It could be something other than the business function activation.

Former Member
0 Kudos

Hi Abdullah

Is thie enhacement spot is called as Active, If yes why there is no column for status in implementation area (as per your screen snap on Jul 9, 2014 10:46 PM) Why CR not trigger the workflow

Former Member
0 Kudos

You might have a different ABAP release level. That's why my screenshot looks a little different than yours. If you double-click the implementation name, it will definitely show you whether that implementation is active or not.

Former Member
0 Kudos

Hi Abdullah

I try to create vendor by assiging WS75700040 and this time it works fine upto step 3 for me mean means I can  do Final Processing  and Approve  also but CR Status remains (Workflow is currently being processed) and remains foreware.
When I checked SWEL for thi\s it shows object Type 'BUS2250' (created) and for object Type 'BUS2250' (Processed) with Green Indicatior.I can see Created CR in MDG staging area only as inactive .Here my question is that even if  I approve CR and workitem is also processed correctly why it is showing unactive in MDG staging area and not replicated to ECC BUT000 table after CR approval as well?

Former Member
0 Kudos

SWEL is only used to find whether a workflow started or not. You need to use SWI1 to display the log of the actual workflow instance. You need to analyze that log to see why it didn't activate. For WS75700040, activation step is TS75707953 (step 298 in this specific workflow template). Verify that it was executed correctly.

Former Member
0 Kudos

Hi Adbullah


It seems that MDGS for Vendor Like UI it is working with simple work flow (WS75700040) but CR got stuck for BRF+ workflow which is delivered ny SAP (WS54300005).Guess something releated to get agent table for BRF+ from client 000. I can see UI for GET_AGENT screen when I go through IMG node 'Assign Processor to Change Request Step Number in BRFplus for Supplier' but when try to open BRF+ transaction in command window it opens screen saying that no application created .

So having dought that some ithing must be wrong while importing application 'MDG_BS_ECC_SUPPLIER_WF_CUSTM' from client 000.

Is any way so that we can validate all parameters for the application 'MDG_BS_ECC_SUPPLIER_WF_CUSTM' are correct or not?


BRF Plus in my system  looks like as

But in another it looks like as

I am in bit confusion which is correct here?

Former Member
0 Kudos

The first one is what you should see when you start the transaction from MDGIMG. The second is also correct.

Former Member
0 Kudos

Hi Abdullah

Are you saying that first screen shot is also OK for BRF+. If Yes then why is not showing rule,expression as per second screen and directly shows only decesion table.

Can you send me for any MDGS active BRF+ screen snap?

Former Member
0 Kudos

mine looks exactly like the first one you have.

Former Member
0 Kudos

Hi Abdullah

Any clue from below screen

Also as per SAP note 6844669 it is program error and need to implement correction.

Is note 765564 has any revalance in  this issue?

Former Member
0 Kudos

I couldn't find OSS note 6844669 and OSS note 765564 does not seem to be relevant.

This screenshot tells me there is an error in the agent assignment. You should be able to debug function module USMD5_CREQUEST_ROLE_DET (the function module is called from rule AC75700139 from your screenshot above). Place a break-point in the function, then go to transaction SWPR and find the workflow instance with this error. Then, click "Restart Workflow." The debugger should open and you should be able to trace it to see where it fails and why.

Former Member
0 Kudos

Hi Abdallah

I am attaching both the sap notes for your referance

Also find that in one of the system WS53100044 is assigned to CR Type instead of WS54300005 and as per GET_AGENT decesion table

Step no 80 is added in decesion tables but is it not defined under node Define Change Request Step

So is is necessary to add step no 80 in this case in GET_AGENT table although it is not assi\gned to WS53100044?

Where we need to define step no 80 and assigned to WS53100044?

Why step no  6 and 7 are not mentioned in GET_AGENT table? It is not showing in GET_AGENT table assigment also.

It is working fine uptill step no 3 only

Former Member
0 Kudos

Hi Abdullah

As per one of the reply for thread

is '

Verify that you have an entry in SWEYPV with BUS2250 and no receiver. The receiver type has to be empty. Also, check the event traces (transaction SWELS and SWEL) and see whether the event is being triggered correctly and what receiver handles it.

But as per SAP help link https://help.sap.com/erp_mdg_addon61/helpdata/en/c6/472d8078e440c28ebc65e71ed5c620/content.htm?frame... it specifies that we have to maintain reciver type FM also SWW_WI_CREATE_VIA_EVENT_IBF.

It is maintain in our systen as per below

I am in confusion now as you said I have to leave receiver FM as empty but SAP help says we have to maintain it.

After maintaing and assignment of WS53100044 to CR type for supplier it works upto step 3 means I can do final processing for CC code as well as PO data.But then it shows CR status as 'Dependent Data to Be Processed/Approved' and I can not see any workitem any where and as per SWEL it says no receiver found.

Here I have question from where desesion table ges CR status? Where it is maintained? Is it harcoaded by SAP as per WF Template?

Former Member
0 Kudos

I said the "receiver type" not the "receiver type function module". From your screenshot, you can see the receiver type field is already blank (4th field from the top).

Former Member
0 Kudos

Hi Abduullah

Apologies for not reading it carefully.

Can you explain from whree CR steps assigned to CR type in desion table and it;s status is taken as description maintained under node Edit Statues for change request step does not mataches with description appeared in decesion table?

Is it necessary to custimisze node Define steps for Rule Based Workflow?

My CR Status updates as per below

  1. Before Submission : 02: Changes to be executed
  2. After Submission : 01:To be considered and Approved
  3. After Reviewer approves : 09: Dependant Data to be processed /Approved
  4. After Purchase reviewer Finalize processing :09: Dependant Data to be processed /Approved
  5. After Finainace reviewer Finalixe processing : 09: Dependant Data to be processed /Approved
  6. Now I can not see CR any where even though CR step 04 and 04 assigned to my user ID
Former Member
0 Kudos

Sure, I could. However, this is not related to the original question in this thread. This thread has been going on for a long time and I'm not sure what the resolution is or whether your original problem is fixed. If any of the answers above answered your original question, please close this thread. For the new question, please open a new thread.