cancel
Showing results for 
Search instead for 
Did you mean: 

MDC Consolidation: Pie Chart is shown in Green Colour even there is an error in Standarization Step

deepakmk1996
Explorer
0 Kudos

Hello MDC Experts,

We are creating Vendor via MDC Process via File Upload using Fiori Tile( Import Data for Consolidation).

We are creating only one vendor at a time. In the Standarization Step, we are validating Address Data and if there is any error we are rasing the error in the same step

But the error is not logged properly in the Pie Chart of the Fiori. Pie Chart is showing in Green Color instead of red, which is not correct behaviour.

There are 3 Status in Standarization Step: Accurate,Defective and Modified Record

But in this case it is coming as Accurate instead of Defective record. Please find attached Screenshot for your reference.

Could you please let know, what could be the issue and let us know how this can be solved.

Accepted Solutions (0)

Answers (2)

Answers (2)

Manikandaraja
Explorer
0 Kudos

Hi Deepak,

Which release of MDC components you are using.

Your address standardization based on BAS or HANA smart data quality? Are you using custom adapter class for Standardization.

For example: if you are using address standardization with BAS then the adapter class is CL_MDC_ADAPTER_BP_BAS_STD.

In this adapter class check the method KPIS_FOR_STANDARDIZATION. Generally the Pie chart information's are updated with the structure MDC_ADAPTER_KPI_STD.

So in this method check the KPIS at line no: 90 to 92 ( defective records should be updated to at line no 91 )

Please refer the below screen shot and let me know if any further details required.

Thank you

Best Regards

Mani

0012anirban
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Deepak,

Could you share what is the error which you are getting? There is definitely a mismatch between the error count and the pie chart, but it would be good to see what the error is.

Also is this happening always, or it's a onetime issue?

Regards

Anirban

deepakmk1996
Explorer
0 Kudos

Hi Anirban,

Yes this is happening always. Please find attached screen shot of error.

Thanks

Deepak

0012anirban
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi deepakmk1996

I would suggest you raise an OSS message. Without looking at the system setup it would be difficult to suggest what is causing this issue.

If you get a solution via OSS, I would request you to share the resolution in this forum.

Regards

Anirban