cancel
Showing results for 
Search instead for 
Did you mean: 

MaxDB Upgrade, unable to establish DB instance session

Former Member
0 Kudos

Hi all, I am trying for to perform a SAP DB upgrade from 7.3.0.28 to version 7.5.0.21. My problem is that when I execute command SDBUPD the following messages appear on screen almost immediately and the update is terminated:

beginning to check sap db instances

start new instance update

cannot establish database instance session

I followed the instructions in the upgrade guide and notes mentioned but this issue is nowhere mentioned. I am not a database specialist so any help and/or suggestions are more then welcome.

Thanks in advance, Tiest

Accepted Solutions (1)

Accepted Solutions (1)

roland_mallmann
Employee
Employee
0 Kudos

Dear Tiest,

it seems there's a problem with your X_server (also called Vserver). It sounds like the VServer process is hanging. To check, you could either try:

- stopping and restarting the Vserver (using: 'x_server stop' and 'x_server start')

- to connect to localhost using dbmcli: 'dbmcli -n localhost -d <SID> -u <dbm-user>,<password>'

If both don't work, you might need to perform the steps provided by OSS/CSS note 786635.

Hope that helps.

Regards,

Roland

P.S. Please also state the operating system (OS) you're using in your answer.

Message was edited by: Roland Mallmann

Former Member
0 Kudos

Roland, thanks for your reply, when i execute the dbmcli command you mentioned, the following error appears: "Error! Connection failed to node localhost for database BSP: connnection refused". Again a connection issue, any idea what can cause this error? I am running my SAP MiniWAS instance from a laptop with XP Prof as operating system. Thanks, Tiest

roland_mallmann
Employee
Employee
0 Kudos

Hi Tiest,

is the vserver/xserver service currently runnning on your machine? Please check if the XServer Service is running.

If <b>is</b> running, and the error still occurs, then possibly some kind of firewall is blocking it. In that case, do you maybe have a firewall active?

If the Xserver <b>is not</b> running, then please start it and try to connect again.

Regards,

Roland

Former Member
0 Kudos

Mmm, yes I do have a firewall running on my laptop and the Miniwas installation completely resides on my laptop so, yes the xServer is running. Will re-try the installation by turning of my firewall. I will keep you posted.

No luck again, I don't get it I have database in state admin, stopped x_server and still same error message regarding the DB instance session. Tiest

roland_mallmann
Employee
Employee
0 Kudos

Hi Tiest,

could you please (re)try the following:

- shutdown your firewall

- make sure x_server is running ('x_server start')

- issue 'dbmcli -n localhost -d <SID> -u <dbm-user>,<password>'

If there's still an error at the dbmcli-command, then please try:

- issueing 'ping localhost' (normally, the IP address of 'localhost' is the standard loopbackaddress of 127.0.0.1)

-> Please copy all output from the above commands into this thread.

---

Maybe on your machine there's a problem with 'localhost'?

Could you also check your <drive>:\<Windows>\system32\drivers\etc\hosts file for the 'localhost' entry?

Regars,

Roland

Former Member
0 Kudos

Ronald, below the results from the commands you provided to me:

- Shutdown Firewall - <i>done</i>

- Bring database in status Admin - <i>done</i>

- Started X-Sever - <i>done</i>e

Result: 19720 INFO: XSERVER started

- Issued DBMBLI command - <i>done</i>

Result: Error! Connection failed to node localhost for

database BSP: connection refused

- pinged localhost - <i>done</i>

Result: Ping Statistics for 127.0.0.1:

Packets: sent=4 received=4 lost=0 (0% Loss)

- Check entries in hosts.ini file - <i>done</i>

Result: 127.0.0.1 localhost

169.254.25.129 OFFICETVG.accenture.com #Miniwas

Hope this give you the information to help me with my upgrade issue, thanks for you time. Tiest

roland_mallmann
Employee
Employee
0 Kudos

Hi Tiest,

ok, another test. Please try the following from the commandline directly:

x_server -D9

This will start the x_server in the foreground and will show some startup lines.

Now try the dbmcli-command again (with the -n localhost). The x_server console output should show some connect information lines. Please enter all output in this message or if it's over 50 lines, then send it to: roland.mallmann@sap.com

If NO additional lines appear from the dbmcli connect, please recheck your firewall config. Maybe you've got Windows XP SP2's firewall still enabled (or partly).

Regards,

Roland

Former Member
0 Kudos

After having executed the x_server -D9 and dbmcli command, the following two windows appeared:

<b>x_server</b>

C:\>x_server -D9

19705 INFO: Loading default TCPIP-DLL, ( 'sqltcp.dll')

19707 INFO: WINSOCK: 2.0, SQLTCP-DLL: 7.3.1

19751 INFO: XSERVER started, 'NT/INTEL 7.3.0 Build 028-000-087-417'

19722 INFO: Service port is 7200

19723 INFO: Opened listen socket 1880

19724 INFO: Segment sizes, sd: 1880, min: 1024, max: 8280

19725 INFO: Listening on socket 1880

19726 INFO: Accepting ...

19722 INFO: Service port is 7210

19723 INFO: Opened listen socket 1856

19724 INFO: Segment sizes, sd: 1856, min: 24, max: 320

19725 INFO: Listening on socket 1856

19726 INFO: Accepting ...

19725 INFO: Listening on socket 2500528

19726 INFO: Accepting ...

19727 INFO: Accepted connection, socket: 1844

19726 INFO: Accepting ...

19728 INFO: server thread started, TID:0x9F0

19731 INFO: Rec. request packet - Class. 91, MyRef: -1, PeerRef: 1, Service: 4,

SERVERDB 'BSP', ClientDB: ''

19743 INFO: Connect req. received, SERVERDB: BSP, SenderRef: 1, PacketSize: 163

4, MaxDataLen: 16336

19724 INFO: Segment sizes, sd: 1844, min: 1024, max: 16384

19732 INFO: Entering data transmission, TID:0x9F0

19733 INFO: Request packet read ( 72 bytes ), Ref:2544

19734 INFO: Local request returned, Ref:2544, CommState = 0

19735 INFO: Local receive returned, Ref:2544, CommState = 0

19736 INFO: Reply packet send ( 3 bytes ), Ref:2544

19733 INFO: Request packet read ( 16 bytes ), Ref:2544

19734 INFO: Local request returned, Ref:2544, CommState = 0

19735 INFO: Local receive returned, Ref:2544, CommState = 0

19736 INFO: Reply packet send ( 240 bytes ), Ref:2544

<b>Dbmcli Command window</b>

C:\Documents and Settings\martin.van.gool>dbmcli -n localhost -d BSP -u control,

control

dbmcli on localhost : BSP>

Does this give you any more information on how to solve my issue? Thanks, Tiest

roland_mallmann
Employee
Employee
0 Kudos

Dear Tiest,

the output you entered displays no errors. It seems you were perfectly able to connect with 'dbmcli -n localhost -d BSP -u control,control'.

In that case, you could try SDBUPD again with that very user.

The problem will still not be gone totally. It maybe so that there are permission problems on your system, making it hard for the Xserver service to run normally.

Can you tell me with which user the Xserver service logs on with? Is it the Local System account or another user? Do both have permissions on directories & files of your MaxDB installation?

Regards,

Roland

Former Member
0 Kudos

Roland, sorry for asking this question; how can I check the X-server user? I am not a databae wizard so I have not a clear idea. Thanks, Tiest.

roland_mallmann
Employee
Employee
0 Kudos

Hi Tiest,

you can check the Xserver service in your Windows Services program. Just doubleclick the 'Xserver' service to see its properties. Then take a look at the tab named 'Log On' to see which user is used by the service to logon with, it's either the Local System account, or a specified user account.

Regards,

Roland

Former Member
0 Kudos

Roland, sorry for missing a day but I have checked for existance of a x_server process using the Windows Task Manager but I could not find any x_server processes there although I know for sure the server is running. Any suggestions on how to see my services differently, e.g. different application or so? Thanks, Tiest.

roland_mallmann
Employee
Employee
0 Kudos

Hi Tiest,

the Windows process name of the x_server is 'serv.exe', sorry for not tellung you before. You should be able to find that process in the Task Manager if the x_server is running.

To check however with which user it logs on with, you need to check your Windows Services. You'll either find those under your Administration Tools, or the Control Panel.

Regards,

Roland

Message was edited by: Roland Mallmann

Former Member
0 Kudos

Roland, I have found the process in the task manager: serv is running. Can you please explain to me what to look for in the Administration Tools? I do not know how to figure out which and/or who is x-server there and therefore which user is logging on. Newbie here so, be patience with me Tiest.

roland_mallmann
Employee
Employee
0 Kudos

Hi Tiest,

np, we'll get there.

Ok, please try either the following to see your services:

1.) From the 'Start' button, choose:

- 'All programs'

- 'Administrative Tools'

- 'Services'

2.) From the 'Start' button, choose:

- 'Settings'

- 'Control Panel'

- 'Services'

3.) From your desktop, rightclick your 'My computer' icon and choose 'Manage'. From there, choose:

- 'Services and Applications'

- 'Services'

In the Services Windows, please search for the 'Xserver' service. If you've found it, doubleclick it and then on the appeared window, select the 'Log On' tab. Please tell me which user is then displayed as being used by this service to logon with.

Regards,

Roland

roland_mallmann
Employee
Employee
0 Kudos

Dear Tiest,

we weren't sure if the Local System Account was being used on your system, so we wanted to be at least 100% sure about it. If it had been another user, that user might not have had certain permissions on files/directories, causing all kinds of problems.

As the above now can be ruled out, the strange thing that remains, is that when you started the Xserver in the 'Debug' mode (x_server -D9) the connect using dbmcli -n localhost worked.

Can you reproduce that effect every time? In short, I'd like you to try the following:

1. Stop Xserver ('x_server stop')

2. Restart Xserver in Debug ('x_server -D9')

3. Try to connect again with 'localhost' as the hostname ('dbmcli -n localhost -d BSP -u control, control')

4. If number 3 is working, then stop the dbmcli-session (enter 'bye' or 'exit' to leave it), BUT don't close the DOS-box/Window. Instead, try calling SDBUPD from there, using the path to the SDBUPD file where the MaxDB 7.5 software resides.

Please let me know how this worked out for you.

Regards,

Roland

Former Member
0 Kudos

Oke, now we are getting somewhere I think, when executing the dbmcli command with localuser I receive the following error: Error! Connection Failed to node localhost for database BSP: ERR_USRFAIL: user authorization failed. What is wrong with this user, I haven't seen this error before and do rememeber having this done before. Does this bring a new area of troubleshooting? Thanks for your continued support, Tiest.

roland_mallmann
Employee
Employee
0 Kudos

Hi Tiest,

in my last answer, I made a small typing error. The command in step 3 has a 'blank' between the user and password 'control'. It should be like:

dbmcli -n localhost -d BSP -u control,control

Can you try running this as step 3? This command (with user & password) worked before, if you yourself didn't change anything on your machine, then it should still work.

Regards,

Roland

Former Member
0 Kudos

Roland, we did get one step further, more activity was shown in the command window, below the new error message I am receiving:

beginning to check sap db instances

existing instance:

0: BSP "C:/sapdb/BSP/db" 7.3.0.28

1: none

please enter instance id: 0

please enter database manager operators name: control

please enter database manager operators password:

start new instance update

finding instance type...

finding starting release...

finding migration strategy...

looking for running instances...

checking paramfile modifications...

looking for domain user...

checking data consistency for database migration...

MaxDB instance "BSP" not ready to update

checking data consistency for database migration...

looking for backup log position

looking for restart info in cold mode

database state is COLD

restart info by dbm:

First LOG Page => 1044270

Id Restart Record => OFFICETVG.accenture.com:BSP_20050129_110523

Id LOG Info => OFFICETVG.accenture.com:BSP_20050129_110523

Restartable => 1

Used LOG Page => 1108259

Consistent => 0

current log position 1108259

backup log position 1108259

database was stoped without checkpoint

MaxDB instance update exited abnormally at Mo, Jan 31, 2005 at 09:37:16

Thanks for your continued support, Tiest

roland_mallmann
Employee
Employee
0 Kudos

Hi Tiest,

apparently you stopped the database without checkpoint last time. I suggest you do the following before trying SDBUPD again:

1. Move the database into OFFLINE mode:

dbmcli -n localhost -d BSP -u control,control db_offline

2. Move the database into COLD mode:

dbmcli -n localhost -d BSP -u control,control db_cold

3. Make a full data backup (for migration) in the COLD mode, using the Database Manager GUI.

Regards,

Roland

Answers (6)

Answers (6)

Former Member
0 Kudos

Hello Tiest van Gool:

I had the same problem. I resolved it doing this:

1- Control panel -> administrative tools -> Services

2- Search XServer and Stop it (see the context menu)

3- Start the set up's DB

Surely works ok.

Now, see if the active server is active when you start up your miniwas:

C:\MiniWAS>REM =====================================================

C:\MiniWAS>REM Set the Environment for the DB Connect

C:\MiniWAS>REM =====================================================

C:\MiniWAS>set DBMS_TYPE=ada

C:\MiniWAS>set PATH=C:\sapdb\programs\bin;C:\sapdb\programs\pgm;C:\WINNT\system3

2;C:\WINNT;C:\WINNT\System32\Wbem;;C:\MiniWAS;C:\sapdb\programs\bin;C:\sapdb\pro

grams\pgm;C:\sapdb\programs\sap;C:\sapdb\programs\bin;C:\sapdb\programs\sap;C:\s

apdb\programs\pgm

C:\MiniWAS>REM =====================================================

C:\MiniWAS>REM Start the Database (SAP-DB)

C:\MiniWAS>REM =====================================================

C:\MiniWAS>cmd /c strdbsBSP.cmd

C:\MiniWAS>set DBNAME=BSP

C:\MiniWAS>x_server

18641 ERROR: XSERVER is already running!

C:\MiniWAS>dbmcli -U c db_warm

OK

Database BSP successfully started !

C:\MiniWAS>REM =====================================================

C:\MiniWAS>REM Start SAP System

C:\MiniWAS>REM =====================================================

etc.etc.

If the output say that x_server is not install, open a DOS console (start->run->type cmd), after that proceed as follows:

C:\sapdb\programs\pgm>x_server -h start

correct use of x_server is:

install as service :: install

remove service :: remove

start server :: start

stop server :: stop

C:\sapdb\programs\pgm>x_server install

19709 INFO: Service 'XServer' installed successfully

C:\sapdb\programs\pgm>x_server start

19720 INFO: XSERVER started

Tell me if my help was helpfull.

LUCK!!.

stefan_seemann
Employee
Employee
0 Kudos

Hello,

have you checked the recycler wether the deleted SAP DB folder is still in it ? If so I would suggest to restore it. Then try the db_drop again.

Since the database has a lot of registry keys, even if the files are deleted the new installation will fail due to the existance of these keys.

The easiest way now would be to reinstall the kernel software. You neeed the database software anyway.

Do you have the installation package on your server ?

If so I would suggest to go to that folder and run this command: sdbinst -package "Database Kernel" -depend c:\sapdb\J2E\db

This should work.

Afterwards the connect to the database should work again.

Hope that helps, Stefan

PS: Unfortunately we are using the other guys case to discuss this issue. I am sorry for that.

Former Member
0 Kudos

Thanks Stefan. It's great help.

Restoring from recycle worked fine. Installation is now successful.

--Satya

PS :- My apologies for starting the query with existing thread

stefan_seemann
Employee
Employee
0 Kudos

Hello,

the Database Kernel 7.5.00.07 32 bit in c:/sapdb/j2e/db

is missing.

To drop the database

dbmcli -s -d J2E -u control,control

>db_stop

>db_drop

But then all the data inside of the database is lost.

with "sdbuninst -all" all the database software will be

deleted when there is no other instance on that host.

Best regards, Stefan

Former Member
0 Kudos

Hi Stefan,

dbmcli -s -d J2E -u control,control

Gives me the following problem

C:\WINDOWS\system32>dbmcli -s -d J2E -u control,control

Error! Connection failed to node (local) for database J2E: dbmsrv executable not found

And "sdbuninst -all" complains that remove all instances before removing "Database Kernel"

I don't have any other instance and no worry of loosing data. Please let me know if there is any other way to drop this database.

thanks

--Satya

stefan_seemann
Employee
Employee
0 Kudos

Hello,

this message just means that the dbmsrv.exe executable doesn't exist.

When you run dbmcli -s db_enum

You get the INSTROOT Path like c:\sapdb\J2E\db

under c:\sapdb\J2E\db\pgm\ there should be a file dbmsrv.exe.

Is it there ?

You can run sdbverify to check your installation.

Best regards, Stefan

Former Member
0 Kudos

Thanks Stefan.

I got this problem beause J2E was installed with older MaxDB version and I was trying to install EP which has newer MaxDB version. Andy things went bad from there.

Can I just drop the whole J2E db and start from scratch?

Here is the output of sdbverify.

check dependencies... ok

check rte registration of package... ok

package data is consistent

Database Kernel 7.5.00.07 32 bit in c:/sapdb/j2e/db

-


check files... failed

c:/sapdb/j2e/db/env/QP.py not found

c:/sapdb/j2e/db/sap/sphsapdb.dll not found

c:/sapdb/j2e/db/bin/ireport.py not found

c:/sapdb/j2e/db/Support/Mapfiles/sqlver.map not found

c:/sapdb/j2e/db/misc/drop_demo_db.cmd not found

c:/sapdb/j2e/db/Support/Mapfiles/sqlwhat.map not found

c:/sapdb/j2e/db/Support/Mapfiles/tracesort.map not found

c:/sapdb/j2e/db/cluster/sapdbmscsman.dll not found

c:/sapdb/j2e/db/doc/FirstSteps/Perl/StateSAPDB.pl not found

c:/sapdb/j2e/db/sap/sphsapdb.lst not found

c:/sapdb/j2e/db/doc/FirstSteps/Python/demodbData.py not found

c:/sapdb/j2e/db/env/kernprot.use not found

c:/sapdb/j2e/db/pgm/libSQLDBC.dll not found

c:/sapdb/j2e/db/misc/create_demo_db.cmd not found

c:/sapdb/j2e/db/doc/FirstSteps/sapdbenv.cmd not found

c:/sapdb/j2e/db/misc/SAP/DBTech/dbm.pm not found

c:/sapdb/j2e/db/env/installib.py not found

c:/sapdb/j2e/db/env/WA.py not found

c:/sapdb/j2e/db/symbols/tracesort.pdb not found

c:/sapdb/j2e/db/cluster/stop_clu.exe not found

c:/sapdb/j2e/db/doc/FirstSteps/Precompiler/Makefile.mak not found

c:/sapdb/j2e/db/env/PRECOM.py not found

c:/sapdb/j2e/db/misc/puclst.exe not found

c:/sapdb/j2e/db/doc/FirstSteps/Perl/HowToPerl.html not found

c:/sapdb/j2e/db/symbols/systemrc.pdb not found

c:/sapdb/j2e/db/Support/Mapfiles/sql_run.map not found

c:/sapdb/j2e/db/pgm/diagnose.exe not found

c:/sapdb/j2e/db/symbols/dbmsrv.pdb not found

c:/sapdb/j2e/db/Support/Mapfiles/get_page.map not found

c:/sapdb/j2e/db/Support/Mapfiles/pchtab.map not found

c:/sapdb/j2e/db/symbols/sapdbmscsman.pdb not found

c:/sapdb/j2e/db/doc/FirstSteps/Perl/demodbData.pm not found

c:/sapdb/j2e/db/doc/FirstSteps/ODBC/HowToODBC.html not found

c:/sapdb/j2e/db/Support/Mapfiles/pu.map not found

c:/sapdb/j2e/db/env/DBMVIEWS.py not found

c:/sapdb/j2e/db/misc/sapdb/pythondef/dbm.pyd not found

c:/sapdb/j2e/db/Support/Mapfiles/dbpinstall.map not found

c:/sapdb/j2e/db/doc/FirstSteps/Java/StateSAPDB.java not found

c:/sapdb/j2e/db/lib/python1.5/cmd.py not found

c:/sapdb/j2e/db/env/XDDCOM.py not found

c:/sapdb/j2e/db/Support/Mapfiles/dbmsrv.map not found

c:/sapdb/j2e/db/misc/pchtab.exe not found

c:/sapdb/j2e/db/Support/Mapfiles/odbcreg.map not found

c:/sapdb/j2e/db/pgm/libsqlcls.dll not found

c:/sapdb/j2e/db/symbols/sysrc.pdb not found

c:/sapdb/j2e/db/symbols/serv-clu.pdb not found

c:/sapdb/j2e/db/pgm/pysapdb.exe not found

c:/sapdb/j2e/db/Support/Mapfiles/sapdbmscsman.map not found

c:/sapdb/j2e/db/pgm/sqlinst.dll not found

c:/sapdb/j2e/db/pgm/quickknl.exe not found

c:/sapdb/j2e/db/pgm/TableDefC.dll not found

c:/sapdb/j2e/db/bin/sqlver.exe not found

c:/sapdb/j2e/db/misc/sapdb/dbapi.py not found

c:/sapdb/j2e/db/sap/updcol.exe not found

c:/sapdb/j2e/db/symbols/sqlinst.pdb not found

c:/sapdb/j2e/db/lib/python1.5/optlib.py not found

c:/sapdb/j2e/db/symbols/kernel.pdb not found

c:/sapdb/j2e/db/misc/repman.py not found

c:/sapdb/j2e/db/lib/python1.5/UserList.py not found

c:/sapdb/j2e/db/Support/Mapfiles/service-clu.map not found

c:/sapdb/j2e/db/Support/Mapfiles/diagnose.map not found

c:/sapdb/j2e/db/lib/python1.5/posixpath.py not found

c:/sapdb/j2e/db/env/cserv.pcf not found

c:/sapdb/j2e/db/doc/FirstSteps/Java/HelloSAPDB.java not found

c:/sapdb/j2e/db/symbols/liboms.pdb not found

c:/sapdb/j2e/db/cluster/SAPDBMSCSEx.dll not found

c:/sapdb/j2e/db/misc/sapdb/loader.py not found

c:/sapdb/j2e/db/pgm/StudioUtil.dll not found

c:/sapdb/j2e/db/env/CNR3TAB.py not found

c:/sapdb/j2e/db/Support/Mapfiles/sqlfilter.map not found

c:/sapdb/j2e/db/env/de/ODBCM.de not found

c:/sapdb/j2e/db/misc/sapdb/__init__.py not found

c:/sapdb/j2e/db/misc/sapdb/pythondef/loader.pyd not found

c:/sapdb/j2e/db/symbols/sqlrun.pdb not found

c:/sapdb/j2e/db/pgm/strt.exe not found

c:/sapdb/j2e/db/doc/FirstSteps/Java/HelloSAPDB.class not found

c:/sapdb/j2e/db/pgm/backup.exe not found

c:/sapdb/j2e/db/cluster/serv_clu.exe not found

c:/sapdb/j2e/db/env/en/ODBCM.en not found

c:/sapdb/j2e/db/lib/python1.5/re.py not found

c:/sapdb/j2e/db/doc/FirstSteps/ODBC/Makefile.mak not found

c:/sapdb/j2e/db/symbols/sqlfilter.pdb not found

c:/sapdb/j2e/db/pgm/dbmext.exe not found

c:/sapdb/j2e/db/Support/Mapfiles/kernel.map not found

c:/sapdb/j2e/db/pgm/tracesort.exe not found

c:/sapdb/j2e/db/Support/Mapfiles/liboms.map not found

c:/sapdb/j2e/db/env/en/SQLM.en not found

c:/sapdb/j2e/db/bin/pipe2file.exe not found

c:/sapdb/j2e/db/Support/Mapfiles/sqlinst.map not found

c:/sapdb/j2e/db/bin/xoldci.exe not found

c:/sapdb/j2e/db/pgm/systemrc.exe not found

c:/sapdb/j2e/db/doc/FirstSteps/ODBC/HelloSAPDB.c not found

c:/sapdb/j2e/db/lib/python1.5/site.py not found

c:/sapdb/j2e/db/Support/Mapfiles/quickknl.map not found

c:/sapdb/j2e/db/bin/xservice.exe not found

c:/sapdb/j2e/db/pgm/dbmstop.exe not found

c:/sapdb/j2e/db/pgm/dbpinstall.dll not found

c:/sapdb/j2e/db/Support/Mapfiles/cpclnk.map not found

c:/sapdb/j2e/db/misc/sapdbapi.py not found

c:/sapdb/j2e/db/bin/xtracesort.exe not found

c:/sapdb/j2e/db/symbols/start-clu.pdb not found

c:/sapdb/j2e/db/misc/dbmaperl.dll not found

c:/sapdb/j2e/db/Support/Mapfiles/libhsscopy.map not found

c:/sapdb/j2e/db/symbols/dbpinstall.pdb not found

c:/sapdb/j2e/db/bin/xsql.exe not found

c:/sapdb/j2e/db/misc/instperl.pl not found

c:/sapdb/j2e/db/pgm/service.exe not found

c:/sapdb/j2e/db/Support/Mapfiles/dbmpyd.map not found

c:/sapdb/j2e/db/cluster/SAPDBMSCSRes.dll not found

c:/sapdb/j2e/db/Support/Mapfiles/dbmsrv-clu.map not found

c:/sapdb/j2e/db/pgm/dbmsrv.exe not found

c:/sapdb/j2e/db/symbols/service-clu.pdb not found

c:/sapdb/j2e/db/env/SYSDBACOM.py not found

c:/sapdb/j2e/db/symbols/service.pdb not found

c:/sapdb/j2e/db/env/en/SQLMESS.en not found

c:/sapdb/j2e/db/lib/python1.5/types.py not found

c:/sapdb/j2e/db/symbols/cpcdrv.pdb not found

c:/sapdb/j2e/db/bin/x_python.exe not found

c:/sapdb/j2e/db/misc/sapdb/dbm.py not found

c:/sapdb/j2e/db/lib/python1.5/UserDict.py not found

c:/sapdb/j2e/db/pgm/pu.exe not found

c:/sapdb/j2e/db/sap/grantxdb.dbm not found

c:/sapdb/j2e/db/sap/saprfc.ini not found

c:/sapdb/j2e/db/lib/python1.5/stat.py not found

c:/sapdb/j2e/db/env/XDD.py not found

c:/sapdb/j2e/db/env/XMLIMAPI.py not found

c:/sapdb/j2e/db/Support/Mapfiles/sysrc.map not found

c:/sapdb/j2e/db/Support/Mapfiles/systemrc.map not found

c:/sapdb/j2e/db/doc/FirstSteps/Precompiler/HelloSAPDB.cpc not found

c:/sapdb/j2e/db/symbols/sphsapdb.pdb not found

c:/sapdb/j2e/db/env/ORADDSYN.py not found

c:/sapdb/j2e/db/env/WEBDAV.py not found

c:/sapdb/j2e/db/bin/x_diagnose.exe not found

c:/sapdb/j2e/db/Support/Mapfiles/cons.map not found

c:/sapdb/j2e/db/Support/Mapfiles/cpcdrv.map not found

c:/sapdb/j2e/db/lib/python1.5/ntpath.py not found

c:/sapdb/j2e/db/doc/FirstSteps/Java/DemodbData.java not found

c:/sapdb/j2e/db/misc/sapdb/pythondef/__init__.py not found

c:/sapdb/j2e/db/symbols/cr_param.pdb not found

c:/sapdb/j2e/db/pgm/renparam.exe not found

c:/sapdb/j2e/db/pgm/kernel.exe not found

c:/sapdb/j2e/db/bin/sqlrun.dll not found

c:/sapdb/j2e/db/Support/Mapfiles/sapdbmscsex.map not found

c:/sapdb/j2e/db/Support/Mapfiles/service.map not found

c:/sapdb/j2e/db/sap/dbpinstall.lst not found

c:/sapdb/j2e/db/env/INFO.py not found

c:/sapdb/j2e/db/symbols/slowci.pdb not found

c:/sapdb/j2e/db/env/SYSINFOCOM.py not found

c:/sapdb/j2e/db/env/dbanalyzer75.cfg not found

c:/sapdb/j2e/db/env/ORADDCOM.py not found

c:/sapdb/j2e/db/pgm/sqlfilt.exe not found

c:/sapdb/j2e/db/pgm/libhsscopy.dll not found

c:/sapdb/j2e/db/pgm/dbghelp.dll not found

c:/sapdb/j2e/db/pgm/liboms.dll not found

c:/sapdb/j2e/db/Support/Mapfiles/serv-clu.map not found

c:/sapdb/j2e/db/pgm/sysrc.exe not found

c:/sapdb/j2e/db/lib/python1.5/fnmatch.py not found

c:/sapdb/j2e/db/env/lapps.py not found

c:/sapdb/j2e/db/pgm/python15.dll not found

c:/sapdb/j2e/db/misc/SAP/DBTech/loader.pm not found

c:/sapdb/j2e/db/bin/xkernprot.exe not found

c:/sapdb/j2e/db/cluster/strt_clu.exe not found

c:/sapdb/j2e/db/misc/sapdb/pythondef/sql.pyd not found

c:/sapdb/j2e/db/symbols/libhsscopy.pdb not found

c:/sapdb/j2e/db/Support/Mapfiles/sqlfiltern.map not found

c:/sapdb/j2e/db/env/SHOWCMD.py not found

c:/sapdb/j2e/db/pgm/sqlmsg.dll not found

c:/sapdb/j2e/db/env/de/PRECOMM.de not found

c:/sapdb/j2e/db/env/general.use not found

c:/sapdb/j2e/db/symbols/get_page.pdb not found

c:/sapdb/j2e/db/pgm/dbmstart.exe not found

c:/sapdb/j2e/db/doc/FirstSteps/Python/HowToPython.html not found

c:/sapdb/j2e/db/symbols/dbmsrv-clu.pdb not found

c:/sapdb/j2e/db/Support/Mapfiles/slowci.map not found

c:/sapdb/j2e/db/cluster/dbmsrv_clu.exe not found

c:/sapdb/j2e/db/pgm/lserver.exe not found

c:/sapdb/j2e/db/lib/python1.5/exceptions.py not found

c:/sapdb/j2e/db/misc/loaderaperl.dll not found

c:/sapdb/j2e/db/Support/Mapfiles/libSQLDBC.map not found

c:/sapdb/j2e/db/lib/python1.5/tempfile.py not found

c:/sapdb/j2e/db/doc/FirstSteps/Java/DemodbData.class not found

c:/sapdb/j2e/db/pgm/sqlfiltn.exe not found

c:/sapdb/j2e/db/symbols/sapdbmscsres.pdb not found

c:/sapdb/j2e/db/misc/netvault.txt not found

c:/sapdb/j2e/db/symbols/lserver.pdb not found

c:/sapdb/j2e/db/pgm/slowknl.exe not found

c:/sapdb/j2e/db/cluster/service_clu.exe not found

c:/sapdb/j2e/db/lib/python1.5/os.py not found

c:/sapdb/j2e/db/env/APPS.py not found

c:/sapdb/j2e/db/symbols/libSQLDBC.pdb not found

c:/sapdb/j2e/db/doc/FirstSteps/ODBC/odbcexample.c not found

c:/sapdb/j2e/db/doc/FirstSteps/index.html not found

c:/sapdb/j2e/db/Support/Mapfiles/updcol.map not found

c:/sapdb/j2e/db/symbols/cons.pdb not found

c:/sapdb/j2e/db/misc/dbm.py not found

c:/sapdb/j2e/db/env/SAPDBLOADER.py not found

c:/sapdb/j2e/db/symbols/sapdbmscsex.pdb not found

c:/sapdb/j2e/db/cluster/SAPDBMSCSMan.exe not found

c:/sapdb/j2e/db/Support/Mapfiles/sapdbmscsres.map not found

c:/sapdb/j2e/db/symbols/diagnose.pdb not found

c:/sapdb/j2e/db/lib/python1.5/linecache.py not found

c:/sapdb/j2e/db/doc/FirstSteps/Precompiler/HowToEmbedSQL.html not found

c:/sapdb/j2e/db/doc/FirstSteps/Java/HowToJava.html not found

c:/sapdb/j2e/db/pgm/cr_param.exe not found

c:/sapdb/j2e/db/misc/sapdb/sql.py not found

c:/sapdb/j2e/db/symbols/backint.pdb not found

c:/sapdb/j2e/db/doc/FirstSteps/Java/StateSAPDB.class not found

c:/sapdb/j2e/db/env/repmanEx.py not found

c:/sapdb/j2e/db/misc/updcol.exe not found

c:/sapdb/j2e/db/bin/backint.exe not found

c:/sapdb/j2e/db/Support/Mapfiles/pipe2file.map not found

c:/sapdb/j2e/db/Support/Mapfiles/libsqlcls.map not found

c:/sapdb/j2e/db/Support/Mapfiles/lserver.map not found

c:/sapdb/j2e/db/lib/python1.5/traceback.py not found

c:/sapdb/j2e/db/doc/FirstSteps/Python/HelloSAPDB.py not found

c:/sapdb/j2e/db/lib/python1.5/lib-dynload/dummy.py not found

c:/sapdb/j2e/db/pgm/stop.exe not found

c:/sapdb/j2e/db/Support/Mapfiles/TableDefC.map not found

c:/sapdb/j2e/db/bin/xci.exe not found

c:/sapdb/j2e/db/symbols/sqlwhat.pdb not found

c:/sapdb/j2e/db/symbols/pipe2file.pdb not found

c:/sapdb/j2e/db/symbols/sqlfiltern.pdb not found

c:/sapdb/j2e/db/bin/sqlwhat.exe not found

c:/sapdb/j2e/db/env/en/DBM.en not found

c:/sapdb/j2e/db/symbols/libsqlcls.pdb not found

c:/sapdb/j2e/db/Support/Mapfiles/slowknl.map not found

c:/sapdb/j2e/db/env/SYSDBA.py not found

c:/sapdb/j2e/db/bin/xsqlro.exe not found

c:/sapdb/j2e/db/env/SYSINFO.py not found

c:/sapdb/j2e/db/symbols/sqlver.pdb not found

c:/sapdb/j2e/db/env/ORADDV.py not found

c:/sapdb/j2e/db/env/ODBC.py not found

c:/sapdb/j2e/db/misc/loader.py not found

c:/sapdb/j2e/db/env/GARBAGE.py not found

c:/sapdb/j2e/db/symbols/TableDefC.pdb not found

c:/sapdb/j2e/db/doc/FirstSteps/Python/StateSAPDB.py not found

c:/sapdb/j2e/db/lib/python1.5/string.py not found

c:/sapdb/j2e/db/doc/FirstSteps/Python/HelloSAPDB-API.py not found

c:/sapdb/j2e/db/pgm/slowci.exe not found

c:/sapdb/j2e/db/Support/Mapfiles/sphsapdb.map not found

c:/sapdb/j2e/db/pgm/cons.exe not found

c:/sapdb/j2e/db/symbols/sql_run.pdb not found

c:/sapdb/j2e/db/env/lsystab.py not found

c:/sapdb/j2e/db/sap/lcinit.bat not found

c:/sapdb/j2e/db/lib/python1.5/glob.py not found

c:/sapdb/j2e/db/Support/Mapfiles/backint.map not found

c:/sapdb/j2e/db/symbols/stop-clu.pdb not found

c:/sapdb/j2e/db/Support/Mapfiles/cr_param.map not found

c:/sapdb/j2e/db/env/CNR3DATA.py not found

c:/sapdb/j2e/db/env/ORADD.py not found

c:/sapdb/j2e/db/env/en/PRECOMM.en not found

c:/sapdb/j2e/db/Support/Mapfiles/puclst.map not found

c:/sapdb/j2e/db/env/AS.py not found

check dependencies... ok

check rte registration of package... ok

package data is inconsistent

Database Kernel 7.5.00.18 32 bit in c:/program files/sdb/7500

-


check files... ok

check dependencies... ok

check rte registration of package... ok

package data is consistent

VERIFICATION SUMMARY:

*********************

INVALID PACKAGES: 0

VALID PACKAGES: 15

INCONSISTENT PACKAGES: 1

TOTAL FILES: 970

MISSED FILES: 253

MODIFIED FILES: 0

FILES WITH MODIFIED PERMISSIONS: 0

C:\WINDOWS\system32>

Former Member
0 Kudos

Hi,

I am having the similar problem with the following error.

C:\WINDOWS\system32>dbmcli -d J2E -u control,control db_stop

Error! Connection failed to node (local) for database J2E: dbmsrv executable n

found

C:\WINDOWS\system32>dbmcli -d J2E -u control,control db_drop

Error! Connection failed to node (local) for database J2E: dbmsrv executable n

found

C:\WINDOWS\system32>dbmcli -d J2E -u control,control db_offline

Error! Connection failed to node (local) for database J2E: dbmsrv executable n

found

C:\WINDOWS\system32>

Is there a way to completey drop the instance and start with new installation?

thanks a lot

--Satya

Former Member
0 Kudos

Roland, found it! When accessing the x_server properties the log on tab says: Local system account. Not able to change that, now what? Tiest