cancel
Showing results for 
Search instead for 
Did you mean: 

LOV Sort Order incorrect in Infoview after migration

Former Member
0 Kudos

Hi there,

I am a first time user here, so I am hoping someone out there will be able to help me with an issue we are having where the LOV sort order is incorrect after migrating Universes and Reports between environments. We are using the Import Wizard to migrate and the incorrect sort order only occurs when refreshing Deski reports in Infoview. Running the same query from Desktop Intelligence gives us the correct sort order. The migration consisted of 4 Universes and 4 Reports from Dev to Test. One of the Universe is a Core Universe and the other 3 are linked to it. 2 reports each are linked to 2 of the Derived Universes.

Unfortunately, our organisation are still on BOXI 3.1 SP7/FP7.1 and we have Development, Test and Production environments. Our Test and Production environments are pretty much identical with 8 Windows servers (clustered HTTP/Web Servers, clustered Application servers, clustered BO Enterprise Servers, a File Repository Server and a WebSphere Console Server) whereas our Development environment has everything combined on the one Windows server and uses Tomcat instead of WebSphere. Our back end is Oracle 11g.

So what I have tried is to double check the specific objects in Designer have 'Import with Universe' selected and also check the Universe Parameter FORCE_SORTED_LOV is set to YES. I have also trawled through numerous forums, and although I have found similar occurrences, I have been unable to find an answer or fix that works. Is there something that I have missed here? Is it related to having a Core Universe? Or could it be related to the different infrastructure between our Dev and Test environments?

This is not something our organisation have been worried about in the past however we have a contractor on site working on these new Universes and Reports, so would like the sort order retained after migration.

I look forward to hearing any responses.

Thanks,

Vinnie

Accepted Solutions (0)

Answers (1)

Answers (1)

former_member198519
Active Contributor
0 Kudos

Did you check the property of the object in designer to set "export with universe" ? check the option "export with universe" and then export the universe before testing the Infoview report again

Former Member
0 Kudos

Hi Kuldeep,

Sorry, I made a typo in my original post. I used the word 'Import' instead of 'Export'. What I should have said is that I checked the specific objects in Designer to make sure they have the option 'Export with Universe' checked.

So to answer your question, yes, I have done that but it still didn't help.

Thanks.