cancel
Showing results for 
Search instead for 
Did you mean: 

Login prompt appears for web app when sql db is not on same server as WebAp

Former Member
0 Kudos

Hi,

I am deploying a VS2005 web application on a server (which has crytalReportsviewer); lets call that server A. The database the crystal reports access are on a different server, server B. In this scenario, when I run the web application, and try to bring up the reports on the web page, I get login prompt. Even if I provide valid login credentials (I have set up a user for this purpose the behavior is erratic; for some reports the report is displayed and for others it errors out with 'unknown error' message.

If I put the sql db on the same server, it works fine.

I use the crystal reports application to update the database source. When I do this, I use Ole db connection and set the 'integrated security' to true. But setting the integrated security to true does not bypass the login screen on the web app.

My question is, how do I set up the report database parameters (connection string etc) so that the user of the web application does not have to go through the login screen when the web application and the sql db does not reside on the same server.

Thanks.

Accepted Solutions (1)

Accepted Solutions (1)

ted_ueda
Active Contributor
0 Kudos

That sound like a [Double-Hop|http://blogs.msdn.com/knowledgecast/archive/2007/01/31/the-double-hop-problem.aspx] issue.

You'd install and configure Kerberos to hop over the credentials - see post: .

Sincerely,

Ted Ueda

Answers (0)