cancel
Showing results for 
Search instead for 
Did you mean: 

LO Extraction (R/3 Error)

Former Member
0 Kudos
199

Hi All,

I am trying to extract Sales Document Item data from the LO

DataSource 2LIS_11_VAITM. I was configuring the R/3 to make the data available

for BW. The steps i followed:

1. Use RSA5 to transfer the 2LIS_11_VAITM datasource.

2. Modified and saved the datasource in RSA6.

3. In LBWE, for the particular Datasource, i activated the update.

4. Deleted the set up tables (LBWG). Selected '11' for Sales.

5. Tried to fill the set up tables using OLI7BW. When i executed the

t-code OLI7BW, i got error 'No Extraction structure active or no BW is

connected'.

I checked the extract structure using LBWE. It was active and also BW

is connected. Could someone help me.

Jonas

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Jonas,

We are doing the LO Cookpit extraction as well and if we follow the

same steps, we've also got the same error msg as you two had got and we

believe you two have resoloved the problem, right? We think the

problem maybe originated from Step 3.

Could you two elaborate on how to do the Step 3? When we tried Step 3

to run LBWE, on the right frame, there are three parallel pencil

buttons, 1st one is "Maintenance", 2nd one is "2LIS_11_VAITM", and the 3rd

one is "Inactive". If we click 1st one Maintenance, it pops up a dialog

box, click Continue, get the msg "You have not changed the extraciton

stucture", if we click 2nd button "2LIS_11_VAITM" and the 3rd button

"Inactive", get the msg "Datasource 2LIS_11_VAITM doesn't exist". We

would be appreciated if you guys could explain in details on how to operate

on step 3!

And btw, if getting a chance, also please let us know on how to

operate on Step 5

TQ

Kumar

Answers (2)

Answers (2)

BerndSieger
Advisor
Advisor
0 Kudos

Hi Jonas,

sometimes the BW only seems to be correctly connected. What is the result if you call function module RSA2_SERV_BW_CONNECTED in the SE37 in test mode (F8)? It has to return an 'X' for field "CONNECTED". Only then the BW has been connected successfully.

To simulate the other check, which the setup program makes before bringing up the error you could start the SE16 for table TMCEXACT and select the entries for your application (11, I guess). There should be an 'X' in field "UPDACT".

In case the first check fails, contact your basis about connecting the systems.

In case of the second check failing, enter the LBWE and have a look at the traffic lights left to the extract structures. They have to be green for an active updating.

Hope that helps,

Bernd Sieger

Former Member
0 Kudos

Hi all,

this issue periodically comes back...

Bye,

Roberto

Former Member
0 Kudos

What exactly did modify in RSA6?

Did you check, if your modification of the DataSource could not be done in LBWE, which is recommended for LO-Cockpit DataSources?