cancel
Showing results for 
Search instead for 
Did you mean: 

KM-COL Upgrade SP10 to SP13 - No rooms in the directory

Former Member
0 Kudos

After an upgrade from SP10 to SP13 all rooms disapeared from the room directory. However by calling the full URL they still exist. Does anyone have a clou on how to restore this?

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi all,

The problem is solved in our system and not by the earlier stated safe mode of the J2EE server.

First of all please check if the following setting gives results in the room directory: (This is not a real solution yet but if the answer is yes, I know where you'll find the root cause...)

Go to System Admin->System Config->KM->Collaboration-> Room Search Properties

Edit roomsearch in advanced mode and uncheck the Use TREX option. Please reply is the roomearch works afterwards.

To be able to work with TREX again afterwards you will have to perform several steps to setup the right index again. I will write this out at your answer.

Kind regards,

Erik van Putten

detlev_beutner
Active Contributor
0 Kudos

Hi Erik,

that's exactly what I've written. Shouldn't you consider rewarding points... knick-knack...

Best regards

Detlev

Former Member
0 Kudos

Sorry Detlev, you are absolutely right. I typed this message a lot earlier and just posted it.

Mirna,

Do you see no rooms in both the room administrator and the roomdirectory? And what about usage on rooms, is it all gone?

Kind regards,

Erik van Putten

mirnachaanine
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Erik,

I am having the same problem at my current customer. No rooms are showing in the room directory. We are also on EP 6.0 SP13, but you mentioned switching the J2EE from 'Safe Mode' in the config tool which fixed the problem. I would appreciate it if you can let me know where I can find this switch in the configtool.

Thanks a lot for your help.

detlev_beutner
Active Contributor
0 Kudos

Hi Mirna,

did you check my link and the settings at the customers site? It is not very unprobable that this problem is due to this cause instead of the "mode"...

Hope it helps

Detlev

mirnachaanine
Product and Topic Expert
Product and Topic Expert
0 Kudos

Yes, I did. It seems that everything is configured correctly as specified in the link. So, I'm not sure what the problem might be at this point.

Thanks,

Mirna

detlev_beutner
Active Contributor
0 Kudos

Hi Mirna,

> It seems that everything is configured correctly

That's not really the question. "It seems", as you said (Mybe it is, no question). But to check this, you can simply set "Use Trex" to false, see http://help.sap.com/saphelp_nw04/helpdata/en/6b/4e9442c22d1131e10000000a1550b0/frameset.htm

With this, the "old" search functionality is used. If now you see rooms again, you'd that it "seemed" to work, but it did not...

Give it one more try. Even if you don't get it working that way, you are sure then that you can exclude this issue as the source of your problem.

Hope it helps

Detlev

mirnachaanine
Product and Topic Expert
Product and Topic Expert
0 Kudos

I tried with both the TREX option on and then off, and both options do not work!

At this time, the root cause of the problem might be due to something completely different...

Thanks.

Former Member
0 Kudos

Hi Erik,

your question is little confusing. what r u referring. Room directory in KM content? What do u mean by calling full URL? Can you be more specific.

thanks,

Praveen

Former Member
0 Kudos

Praveen,

You're right it's the roomdirectory within KM Collaboration. It was completely empty. The room URL (from the admin screen) was saved to my favorites before the update. And these links still worked, only the directory listing was empty.

I found the root cause now, the SP13 J2EE engine was still running in "Safe Mode", appearently application running on it, like the portal, have problems running like this. I reset the Safe mode switch with the Configtool and restarted the J2EE engine. After this the room directory was completely filled with my earlier ceaed rooms.

Thanks for thinking with me...

detlev_beutner
Active Contributor
0 Kudos

Hi Erik,

this can also be dependent on the new mechanism how the rooms are searched for, now (from SP13 on) using TREX, see http://help.sap.com/saphelp_nw04/helpdata/en/ff/1a9442062bcd6ae10000000a155106/frameset.htm and the link provided there.

Hope it helps

Detlev