Showing results for 
Search instead for 
Did you mean: 

Key figure is displayed as 2.007 not 2007, any solution?

Former Member
0 Kudos

Dear Sirs,

I have a key figure called Year, of type Int 4. This is being filled from a day using the DATE_YEAR function in the update rule.

When it is displayed in Bex Web it is shown as 2. 007 (with a dot and a space). As far as I can see it also saved in this format in the actual data.

How can I display this as 2007 and not 2. 007 ?

I have tried different things, using the nodim() and the trunc() in the update rule. I have also tried to change the scaling factor in Bex Query designer on the key figure.

I am aware that changing the display format in SU3 could solve it, but I would like to solve it independant of the different users, and make it only valid for this key figure.

Can anyone help me?

best regards,

Jørgen Ruud

Accepted Solutions (0)

Answers (1)

Answers (1)

Active Contributor
0 Kudos

Did u try creating a a formula and multiplying the K.F with 1000???

Former Member
0 Kudos


this will not help as the dot in the number represent the thousand notation, so by multiplying it with 1000, it will become 2. 007. 000.

So I guess my question can be summed up as: how do i remove the thousand notation for a given key figure?



Edited by: Jørgen Ruud on Jan 8, 2008 9:38 AM

Former Member
0 Kudos

If your question is how to change thousand notation,

you have to modify the the infoobject property of that key figure..

go to RSD1 , enter your keyfigure..go to Additional property.

and change Display setting...

I hope it helps.

Best regards,


Assign point if it helps.

Former Member
0 Kudos


this does not help, I have already trying to do this in the query. By changing the display (scaling factor) to eg. 1000 I can manage to display 2 (*1000) if the value is 2000.

However no matter what the scaling factor is, I can't show 2. 007 as 2007


Edited by: Jørgen Ruud on Jan 9, 2008 7:22 AM